Advanced search

Message boards : Graphics cards (GPUs) : Quad SLI only 3 GPUs detect under BOINC

Author Message
AusTerror
Send message
Joined: 11 Jul 07
Posts: 1
Credit: 14,078,188
RAC: 0
Level
Pro
Scientific publications
watwatwatwatwatwatwatwatwat
Message 12230 - Posted: 31 Aug 2009 | 5:54:48 UTC

Howdy guys,

I have a Phenom quad core which has been happily crunching GPGPU stuff for a long while with 1x 9800GX2 card.

Recently I installed a 2nd 9800GX2 and connected the SLI connector. SLI is not enabled as I have 4 LCDs connected. BOINC detects 3 GPUs and assigns 3 WUs. The WUs appear to finish without error.

I am running Windows Server 2008 SP1 64bit with 6GB of RAM, with Nvidia Drivers 190.62 and I am running 6.10.0 version of BOINC. If I enable SLI BOINC reports 2 GPUs.

Does anyone have any ideas about how I would get all 4 GPUs recognised by BOINC?

thanks!

Profile Jet
Send message
Joined: 14 Jun 09
Posts: 25
Credit: 5,835,455
RAC: 0
Level
Ser
Scientific publications
watwatwatwatwat
Message 12232 - Posted: 31 Aug 2009 | 10:45:40 UTC - in response to Message 12230.

Hi, check, how your GPU's is assigned by PCI-E, by GPU-Z utility, for example.
How much PCI-E slots do your MoBo has ? Probably, there is a need for replacenet of one GPU to ahother PCI-E slot.

Profile Paul D. Buck
Send message
Joined: 9 Jun 08
Posts: 1050
Credit: 37,321,185
RAC: 0
Level
Val
Scientific publications
watwatwatwatwatwatwatwatwatwat
Message 12233 - Posted: 31 Aug 2009 | 11:54:15 UTC

Some BOINC versions will not see all the GPUs because GPU 1 (second GPU) has a slightly different memory size. May need "use all GPU" flag in cc_config to overcome. Not sure if this was fixed in later versions or not.

Richard Haselgrove
Send message
Joined: 11 Jul 09
Posts: 1423
Credit: 3,517,431,451
RAC: 646,139
Level
Arg
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 12234 - Posted: 31 Aug 2009 | 12:11:49 UTC - in response to Message 12233.

Some BOINC versions will not see all the GPUs because GPU 1 (second GPU) has a slightly different memory size. May need "use all GPU" flag in cc_config to overcome. Not sure if this was fixed in later versions or not.

That was fixed for BOINC v6.6.27 and later:

view 2 GPUs as equivalent if their memory differs by <30%. (maybe their memory differed slightly from the most capable one)

Post to thread

Message boards : Graphics cards (GPUs) : Quad SLI only 3 GPUs detect under BOINC

//