Advanced search

Message boards : Graphics cards (GPUs) : ACEMDBETA 6.37 (cuda31) for Linux and Windows

Author Message
Profile GDF
Volunteer moderator
Project administrator
Project developer
Project tester
Volunteer developer
Volunteer tester
Project scientist
Send message
Joined: 14 Mar 07
Posts: 1947
Credit: 629,356
RAC: 0
Level
Gly
Scientific publications
watwatwatwatwat
Message 19368 - Posted: 9 Nov 2010 | 14:06:56 UTC

Are there any issue with the CUDA3.1 beta applications?

gdf

Oktan
Send message
Joined: 28 Mar 09
Posts: 16
Credit: 920,827,954
RAC: 237,196
Level
Glu
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 19369 - Posted: 9 Nov 2010 | 15:09:20 UTC - in response to Message 19368.

Hi GDF im on linux 64 Ubuntu 10.10 6.12 dident work well on my setup 100hrs per unit so i aborted but 6.37 worked well sadly low points.

Keep up the good work:)

Profile nenym
Send message
Joined: 31 Mar 09
Posts: 137
Credit: 1,212,687,943
RAC: 16,712
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 19370 - Posted: 9 Nov 2010 | 15:56:24 UTC

ID 31329 XP x_64 GTX260 65nm rev A.2 one tasks errored out, one finished in 483s.
ID 64724 Ubuntu 10.04.1 64bit 9600GT 4 tasks errored out. Maybe issue of my configuration, I am running there Folding GPU3 via Wine with 32bit drivers. I am not sure which drivers is GPUGRID using as I am Linux noob.

Profile GDF
Volunteer moderator
Project administrator
Project developer
Project tester
Volunteer developer
Volunteer tester
Project scientist
Send message
Joined: 14 Mar 07
Posts: 1947
Credit: 629,356
RAC: 0
Level
Gly
Scientific publications
watwatwatwatwat
Message 19375 - Posted: 9 Nov 2010 | 18:17:14 UTC - in response to Message 19370.

We are interested in knowing, in order of importance.
1) Does it run?
2) If the speed is fine.

The speed of the beta test on a Fermi GTX480, run with SWAN_SYNC=0, should be around 5ms/step, on a GTX275 around 9ms/step. To check look at the result output.

gdf

Profile nenym
Send message
Joined: 31 Mar 09
Posts: 137
Credit: 1,212,687,943
RAC: 16,712
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 19376 - Posted: 9 Nov 2010 | 18:55:07 UTC
Last modified: 9 Nov 2010 | 18:58:01 UTC

Another two beta tasks Win XP x_64 GTX260 65 nm rev A2, no SWAN_SYC set.
1. 522s, 2. 534s - I turned back OC to factory settings.

Win XP x86, 9600GT, no SWAN_SYC set - 2,533s. Factory clock.

All beta tasks finished after turning clock back on both XP x_64/GTX260 and XP x_86/9600GT.

Profile GDF
Volunteer moderator
Project administrator
Project developer
Project tester
Volunteer developer
Volunteer tester
Project scientist
Send message
Joined: 14 Mar 07
Posts: 1947
Credit: 629,356
RAC: 0
Level
Gly
Scientific publications
watwatwatwatwat
Message 19377 - Posted: 9 Nov 2010 | 19:00:56 UTC - in response to Message 19376.

The 260 is about 10ms/step. Quite nice.

gdf

Alain Maes
Send message
Joined: 8 Sep 08
Posts: 63
Credit: 1,147,437,459
RAC: 162,382
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 19381 - Posted: 9 Nov 2010 | 20:13:05 UTC

Unfortunately nothing but crashes on my Ubuntu 10.10 with GTX470 driver 260.19.12. With 6.06 version everything was fine.

My GT240 on Vista 32 with driver 260.99 though seems to be doing fine.

Happy crunching

Alain

Profile GDF
Volunteer moderator
Project administrator
Project developer
Project tester
Volunteer developer
Volunteer tester
Project scientist
Send message
Joined: 14 Mar 07
Posts: 1947
Credit: 629,356
RAC: 0
Level
Gly
Scientific publications
watwatwatwatwat
Message 19383 - Posted: 9 Nov 2010 | 20:33:20 UTC - in response to Message 19381.

This is odd.
../../projects/www.gpugrid.net/acemdbeta_6.37_x86_64-pc-linux-gnu__cuda31: error while loading shared libraries: libcufft.so.3: cannot open shared object file: No such file or directory


try to reset project.

gdf

Unfortunately nothing but crashes on my Ubuntu 10.10 with GTX470 driver 260.19.12. With 6.06 version everything was fine.

My GT240 on Vista 32 with driver 260.99 though seems to be doing fine.

Happy crunching

Alain

Alain Maes
Send message
Joined: 8 Sep 08
Posts: 63
Credit: 1,147,437,459
RAC: 162,382
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 19388 - Posted: 9 Nov 2010 | 21:54:57 UTC - in response to Message 19383.

Thanks for your fast reply.

Interesting is that after reset the file libcufft.so.3.0 is being uploaded togheter with all the rest.

But for now I am back to 6.06 type WUs.

Will report as soon as I get a new 6.37 type.

kind regards

Alain

This is odd.
../../projects/www.gpugrid.net/acemdbeta_6.37_x86_64-pc-linux-gnu__cuda31: error while loading shared libraries: libcufft.so.3: cannot open shared object file: No such file or directory


try to reset project.

gdf

Unfortunately nothing but crashes on my Ubuntu 10.10 with GTX470 driver 260.19.12. With 6.06 version everything was fine.

My GT240 on Vista 32 with driver 260.99 though seems to be doing fine.

Happy crunching

Alain


Profile skgiven
Volunteer moderator
Volunteer tester
Avatar
Send message
Joined: 23 Apr 09
Posts: 3968
Credit: 1,995,359,260
RAC: 0
Level
His
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 19392 - Posted: 9 Nov 2010 | 23:06:20 UTC - in response to Message 19388.

NVidia's Linux drivers are wantant.

Good Luck,

ftpd
Send message
Joined: 6 Jun 08
Posts: 152
Credit: 328,250,382
RAC: 0
Level
Asp
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 19402 - Posted: 10 Nov 2010 | 6:28:19 UTC - in response to Message 19392.
Last modified: 10 Nov 2010 | 6:29:10 UTC

core_client_version>6.10.58</core_client_version>
<![CDATA[
<stderr_txt>
# Using device 0
# There are 2 devices supporting CUDA
# Device 0: "GeForce GTX 295"
# Clock rate: 1.24 GHz
# Total amount of global memory: 939327488 bytes
# Number of multiprocessors: 30
# Number of cores: 240
# Device 1: "GeForce GTX 295"
# Clock rate: 1.24 GHz
# Total amount of global memory: 939196416 bytes
# Number of multiprocessors: 30
# Number of cores: 240
MDIO ERROR: cannot open file "restart.coor"
# Time per step (avg over 50000 steps): 12.679 ms
# Approximate elapsed time for entire WU: 633.938 s
called boinc_finish

</stderr_txt>
]]>

Received two beta's - one cancelled after 10 seconds and one OK in 10 minutes.
Windows XP-pro 260.99 driver gtx295

Good luck!
____________
Ton (ftpd) Netherlands

Profile skgiven
Volunteer moderator
Volunteer tester
Avatar
Send message
Joined: 23 Apr 09
Posts: 3968
Credit: 1,995,359,260
RAC: 0
Level
His
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 19411 - Posted: 10 Nov 2010 | 12:04:18 UTC - in response to Message 19402.

Name 111-GIANNI_TESTDHFR9-2-5-RND8139_0
Workunit 2059454
Created 10 Nov 2010 8:52:51 UTC
Sent 10 Nov 2010 9:00:13 UTC
Received 10 Nov 2010 11:47:14 UTC
Server state Over
Outcome Client error
Client state Compute error
Exit status 1 (0x1)
Computer ID 71363
Report deadline 15 Nov 2010 9:00:13 UTC
Run time 15.28125
CPU time 13.14063
stderr out

<core_client_version>6.10.58</core_client_version>
<![CDATA[
<message>
Incorrect function. (0x1) - exit code 1 (0x1)
</message>
<stderr_txt>
# Using device 0
# There are 2 devices supporting CUDA
# Device 0: "GeForce GTX 470"
# Clock rate: 1.43 GHz
# Total amount of global memory: 1341849600 bytes
# Number of multiprocessors: 14
# Number of cores: 112
# Device 1: "GeForce GTX 470"
# Clock rate: 1.43 GHz
# Total amount of global memory: 1341718528 bytes
# Number of multiprocessors: 14
# Number of cores: 112
SWAN: Using synchronization method 0
MDIO ERROR: cannot open file "restart.coor"

</stderr_txt>
]]>

Validate state Invalid
Claimed credit 187.279513888889
Granted credit 0
application version ACEMD beta version v6.37 (cuda31)

http://www.gpugrid.net/result.php?resultid=3266818

Profile Bikermatt
Send message
Joined: 8 Apr 10
Posts: 37
Credit: 3,815,467,185
RAC: 171,605
Level
Arg
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 19419 - Posted: 10 Nov 2010 | 21:06:54 UTC

Not running for me. Ubuntu 10.4 GTX 470 driver 260.19.12

Name 138-GIANNI_TESTDHFR9-3-5-RND1365_0
Workunit 2060131
Created 10 Nov 2010 14:00:31 UTC
Sent 10 Nov 2010 14:01:15 UTC
Received 10 Nov 2010 17:21:17 UTC
Server state Over
Outcome Client error
Client state Compute error
Exit status 127 (0x7f)
Computer ID 75881
Report deadline 15 Nov 2010 14:01:15 UTC
Run time 0
CPU time 0
stderr out

<core_client_version>6.10.56</core_client_version>
<![CDATA[
<message>
process exited with code 127 (0x7f, -129)
</message>
<stderr_txt>

</stderr_txt>
]]>

Validate state Invalid
Claimed credit 0
Granted credit 0
application version ACEMD beta version v6.37 (cuda31)

Profile Aardvark
Avatar
Send message
Joined: 27 Nov 08
Posts: 28
Credit: 82,362,324
RAC: 0
Level
Thr
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwat
Message 19420 - Posted: 11 Nov 2010 | 2:22:00 UTC - in response to Message 19419.

A bit late, but Worked OK here, Win7 Pro, GTX260.

Name 80-GIANNI_TESTDHFR9-1-5-RND0853_0
Workunit 2042787
Created 4 Nov 2010 3:15:47 UTC
Sent 4 Nov 2010 10:45:47 UTC
Received 4 Nov 2010 13:08:03 UTC
Server state Over
Outcome Success
Client state Done
Exit status 0 (0x0)
Computer ID 79450
Report deadline 9 Nov 2010 10:45:47 UTC
Run time 591.927441
CPU time 545.6447
stderr out <core_client_version>6.10.58</core_client_version>
<![CDATA[
<stderr_txt>
# Using device 0
# There are 2 devices supporting CUDA
# Device 0: "GeForce GTX 260"
# Clock rate: 1.47 GHz
# Total amount of global memory: 915800064 bytes
# Number of multiprocessors: 27
# Number of cores: 216
# Device 1: "GeForce GTX 260"
# Clock rate: 1.47 GHz
# Total amount of global memory: 915931136 bytes
# Number of multiprocessors: 27
# Number of cores: 216
SWAN: Using synchronization method 0
MDIO ERROR: cannot open file "restart.coor"
# Time per step (avg over 50000 steps): 11.795 ms
# Approximate elapsed time for entire WU: 589.775 s
called boinc_finish

</stderr_txt>
]]>


Validate state Valid
Claimed credit 187.279513888889
Granted credit 280.919270833333
application version ACEMD beta version v6.37 (cuda31)

http://www.gpugrid.net/result.php?resultid=3237311

Profile Anders - sm6uuz
Send message
Joined: 10 Sep 10
Posts: 1
Credit: 2,732,701
RAC: 0
Level
Ala
Scientific publications
watwatwatwatwatwat
Message 19430 - Posted: 11 Nov 2010 | 20:31:21 UTC - in response to Message 19368.
Last modified: 11 Nov 2010 | 20:43:23 UTC

Hello!
I would like to provide feedback on "ACEMDBETA 6:37", and my system setup.

I got 29 WU's and all of them are complete and validated.

Information about the system:
Motherboard: ASUS AT3IONT-I
Graphics card: GeForce GTX460 (1024MB) Sparkle
OS: Ubuntu 10:04 (64bit)
Nvidia Driver: NVIDIA-Linux-x86_64-260.19.12 and cudatoolkit_3.2.12_linux_64_ubuntu10.04
Boinc: boinc_6.10.58_x86_64-pc-linux-gnu

Here is one of the Beta results.
http://www.gpugrid.net/result.php?resultid=3269099
-----
<core_client_version> 6:10:58 </ core_client_version>
<! [CDATA [
<stderr_txt>
# Using device 0
# There ARE two devices Supporting CUDA
# Device 0: "GeForce GTX 460"
# Clock rate: 1.40 GHz
# Total Amount of global memory: 1073414144 bytes
# Number of multiprocessors: 7
# Number of cores: 56
Device # 1: "ION"
# Clock rate: 1.10 GHz
# Total Amount of global memory: 265617408 bytes
# Number of multiprocessors: 2
# Number of cores: 16
MDIO ERROR: can not open file "restart.coor"
# Time per step (avg over 50 000 steps): 20 963 ms
# Approximate elapsed time for Entire WU: 1048.166 s
20:27:50 (5410): Called boinc_finish

</ Stderr_txt>
]]>

Valid
Claimed credit 187.279513888889
Granted credit 280.919270833333
application version ACEMD beta version v6.37 (cuda31)
-----

Maybe it's too late to give feedback.
Greetings Anders

lkiller123
Send message
Joined: 24 Dec 09
Posts: 22
Credit: 15,875,809
RAC: 0
Level
Pro
Scientific publications
watwatwatwatwatwatwatwatwatwatwat
Message 19491 - Posted: 16 Nov 2010 | 1:24:14 UTC - in response to Message 19430.

I was attempting to get some beta WUs for my systems with the GTX260.

11/15/2010 5:23:02 PM | GPUGRID | Message from GPUGRID: ACEMD beta version is not available for your type of computer.


Is there a way to get around this?

Profile skgiven
Volunteer moderator
Volunteer tester
Avatar
Send message
Joined: 23 Apr 09
Posts: 3968
Credit: 1,995,359,260
RAC: 0
Level
His
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 19497 - Posted: 16 Nov 2010 | 11:23:21 UTC - in response to Message 19491.

No and there would be no point; if the team is testing tasks or apps on Fermi cards they don't want to run them on non-Fermi cards, otherwise they would already be available for your card.

Post to thread

Message boards : Graphics cards (GPUs) : ACEMDBETA 6.37 (cuda31) for Linux and Windows

//