Advanced search

Message boards : Graphics cards (GPUs) : Why does gpugrid Not support 257.15?

Author Message
zoom314
Avatar
Send message
Joined: 13 Jun 09
Posts: 26
Credit: 2,309,584
RAC: 0
Level
Ala
Scientific publications
watwatwatwatwat
Message 19599 - Posted: 22 Nov 2010 | 6:15:55 UTC
Last modified: 22 Nov 2010 | 6:47:00 UTC

Why does gpugrid Not support 257.15?

Milkyway and S@H do.

I just get computation error #3(6 of them) when I try and run more than one instance of 6.13, I'd rather use an older cud 2.2, But I see since I use 257.15 that would not work and cuda31 support seems to start at 257.21 and up to 258.xx which I don't like, Once I get past the one WU I'm working on I guess I'll detach from gpugrid. I use XP x64 of course.
____________

Profile skgiven
Volunteer moderator
Volunteer tester
Avatar
Send message
Joined: 23 Apr 09
Posts: 3968
Credit: 1,995,359,260
RAC: 0
Level
His
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 19609 - Posted: 22 Nov 2010 | 14:43:15 UTC - in response to Message 19599.

Just install the 197.45 driver and you will run the cuda 2.2 app. There is no advantage in running a Cuda3.1 app on a GF200 series card.

zoom314
Avatar
Send message
Joined: 13 Jun 09
Posts: 26
Credit: 2,309,584
RAC: 0
Level
Ala
Scientific publications
watwatwatwatwat
Message 19610 - Posted: 22 Nov 2010 | 14:51:05 UTC - in response to Message 19609.

Just install the 197.45 driver and you will run the cuda 2.2 app. There is no advantage in running a Cuda3.1 app on a GF200 series card.

Since I already told You why I can not, I won't. I can not use earlier than 256 cause I use an app there that requires at least 256, So 197.45 will not work with this app(Lunatics_x32f_win32_cuda30.exe, It's an optimized app), And since this app works real well and produces very few #12 errors, I will keep on using 257.15.
____________

zoom314
Avatar
Send message
Joined: 13 Jun 09
Posts: 26
Credit: 2,309,584
RAC: 0
Level
Ala
Scientific publications
watwatwatwatwat
Message 19614 - Posted: 22 Nov 2010 | 16:20:59 UTC
Last modified: 22 Nov 2010 | 16:22:29 UTC

Ok, I can't use anything earlier than 257.15 cause Seti needs this driver as I use an optimized app there(Lunatics_x32f_win32_cuda30.exe can't use any video driver older than 256), So 197.45 and earlier is out, I also found that this 257.15 driver performs best, As to 260.99 I tried It once, It does the same as 258.96. Also 6.10.58 x64 doesn't seem to work any better than 6.10.56 x64 so I don't use It either. So I've detached. As I've returned dozens of good Milkyway WU's from both gpus(It's a GTX295 which has as all GTX295 cards do, 2 gpus on board), I could have downloaded and downloaded gpugrid WU's just to see them fail after a few seconds, But why? Seems this project doesn't like My PC, So I'm gone..

Also upgrading to 6.10.58 from 6.10.56 makes no sense(I've tried It before), Just cause It's newer does not make It better, Only newer.

As to moving Boinc to a different folder, It would not change a thing, I'd have to reinstall other apps and stuff for other projects, So why bother? As It's a waste of My time.
____________

Profile GDF
Volunteer moderator
Project administrator
Project developer
Project tester
Volunteer developer
Volunteer tester
Project scientist
Send message
Joined: 14 Mar 07
Posts: 1947
Credit: 629,356
RAC: 0
Level
Gly
Scientific publications
watwatwatwatwat
Message 19615 - Posted: 22 Nov 2010 | 16:49:47 UTC - in response to Message 19599.

[quote]Why does gpugrid Not support 257.15?

We need a cuda 3.1 driver to run cuda3.1.

gdf

zoom314
Avatar
Send message
Joined: 13 Jun 09
Posts: 26
Credit: 2,309,584
RAC: 0
Level
Ala
Scientific publications
watwatwatwatwat
Message 19618 - Posted: 22 Nov 2010 | 17:01:32 UTC - in response to Message 19615.
Last modified: 22 Nov 2010 | 17:04:06 UTC

[quote]Why does gpugrid Not support 257.15?

We need a cuda 3.1 driver to run cuda3.1.

gdf

In other words this project(gpugrid) won't support cuda 2.3 or cuda 3.0 anything? that sucks. I mean what's wrong with being backwards compatible? You could do this, Seti and Milkyway do, But I guess gpugrid can't do that.
____________

Profile skgiven
Volunteer moderator
Volunteer tester
Avatar
Send message
Joined: 23 Apr 09
Posts: 3968
Credit: 1,995,359,260
RAC: 0
Level
His
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 19625 - Posted: 22 Nov 2010 | 18:44:20 UTC - in response to Message 19618.

People can run the cuda 2.2 app (6.12) but only if they use an older driver (195 to 197.45). If they use a later cuda 3.1 driver they will be allocated a cuda 3.1 app and tasks for it:

If you have a cuda 2.2 to 3.0 driver, you get the cuda 2.2 app and run tasks for it.
If you have a cuda 3.1 or 3.2 driver, you get the cuda 3.1 app and run tasks for it.

Tasks are basically the same but those built for the 3.1 app include cuda 3.1 subroutines, which will not work on a cuda 2.2 app.

VW Bobier, your problem stems from being restricted by another project to use the first cuda 3.1 capable beta driver. This seems to be a bad driver to crunch on the cuda 3.1 app for your system.

If you were not restricted to that one driver you could use a higher driver or go back to 197.45 and crunch tasks on the cuda 2.2app. Unfortunately you can't use the 6.12app as the system determines what app to run based on the driver and allocates accordingly. So yes we are being forced to use an older driver or run the 3.1 app, but without the 3.1 app Fermi's would not work.

zoom314
Avatar
Send message
Joined: 13 Jun 09
Posts: 26
Credit: 2,309,584
RAC: 0
Level
Ala
Scientific publications
watwatwatwatwat
Message 19629 - Posted: 22 Nov 2010 | 19:52:44 UTC - in response to Message 19625.
Last modified: 22 Nov 2010 | 19:59:26 UTC

People can run the cuda 2.2 app (6.12) but only if they use an older driver (195 to 197.45). If they use a later cuda 3.1 driver they will be allocated a cuda 3.1 app and tasks for it:

If you have a cuda 2.2 to 3.0 driver, you get the cuda 2.2 app and run tasks for it.
If you have a cuda 3.1 or 3.2 driver, you get the cuda 3.1 app and run tasks for it.

Tasks are basically the same but those built for the 3.1 app include cuda 3.1 subroutines, which will not work on a cuda 2.2 app.

VW Bobier, your problem stems from being restricted by another project to use the first cuda 3.1 capable beta driver. This seems to be a bad driver to crunch on the cuda 3.1 app for your system.

If you were not restricted to that one driver you could use a higher driver or go back to 197.45 and crunch tasks on the cuda 2.2app. Unfortunately you can't use the 6.12app as the system determines what app to run based on the driver and allocates accordingly. So yes we are being forced to use an older driver or run the 3.1 app, but without the 3.1 app Fermi's would not work.

And since a GTX295 is not a Fermi, But a GT200b chip... I don't have any money for Fermi... And gpugrid may as well be folding, Cause It's supposed to be a Boinc project, But then cross project compatibility doesn't exist here anymore.

Milkyway: works
Seti: works
Gpugrid: doesn't work
____________

Profile skgiven
Volunteer moderator
Volunteer tester
Avatar
Send message
Joined: 23 Apr 09
Posts: 3968
Credit: 1,995,359,260
RAC: 0
Level
His
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 19635 - Posted: 23 Nov 2010 | 0:58:59 UTC - in response to Message 19629.

And gpugrid may as well be folding, Cause It's supposed to be a Boinc project, But then cross project compatibility doesn't exist here anymore.


Nonsense, this project does more than fold proteins and I crunch for over 20 different projects as well as GPUGrid.

You don’t seem to be able to accept that your attachment to a defunct beta driver in order to support a bespoke Seti app is the source of your problem. Accept it and move on.

Post to thread

Message boards : Graphics cards (GPUs) : Why does gpugrid Not support 257.15?

//