Advanced search

Message boards : Graphics cards (GPUs) : 2 X GTX 260 (216 cores) suspending work - high CPU usage

Author Message
Stephenish
Send message
Joined: 24 Mar 09
Posts: 37
Credit: 35,698,253
RAC: 0
Level
Val
Scientific publications
watwatwatwatwatwatwatwat
Message 20407 - Posted: 12 Feb 2011 | 17:09:35 UTC

I notice that sometimes, my i7 920 (hyperthreaded) running 8 cores of AQUA and two GPUs (+.32 CPUs each) will suspend work due to high CPU usage.

I ran across a thread somewhere, where a fellow was limiting CPU usage so the GPUs could take one core to themselves. How would I implement this on my system?

Werkstatt
Send message
Joined: 23 May 09
Posts: 121
Credit: 258,138,755
RAC: 0
Level
Asn
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 20409 - Posted: 12 Feb 2011 | 20:17:07 UTC - in response to Message 20407.

I notice that sometimes, my i7 920 (hyperthreaded) running 8 cores of AQUA and two GPUs (+.32 CPUs each) will suspend work due to high CPU usage.

I ran across a thread somewhere, where a fellow was limiting CPU usage so the GPUs could take one core to themselves. How would I implement this on my system?


http://www.gpugrid.net/forum_thread.php?id=2428

you can find all infos here. You need to install an app_info.xml and you need to know which app's are running on a GTX260 and insert the correct info to your app_info.
But first finish your wu's, they might be killed by restarting with an app_info.xml

Stephenish
Send message
Joined: 24 Mar 09
Posts: 37
Credit: 35,698,253
RAC: 0
Level
Val
Scientific publications
watwatwatwatwatwatwatwat
Message 20411 - Posted: 13 Feb 2011 | 3:31:51 UTC - in response to Message 20409.

Thank you, I think...

My understanding of xml is very limited. I'm running Vista 64 on the machine in question. What would the app_info.xml file do? Would I have to give new file names every time the project changes? How do I choose file names?

Sorry if I'm asking you to hold my hand to cross the street...

Profile skgiven
Volunteer moderator
Volunteer tester
Avatar
Send message
Joined: 23 Apr 09
Posts: 3968
Credit: 1,995,359,260
RAC: 0
Level
His
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 20415 - Posted: 13 Feb 2011 | 11:34:53 UTC - in response to Message 20411.

Hi Stephenish, perhaps your problem is just a Boinc setting?
In Boinc Manager (Advanced View) Click Advanced, Preferences and under the processor usage tab change the default value for While processor usage is less than to zero. I think the default is 25%

However, If you want to fee up 2 CPU threads in Boinc and use swan_sync=0 read the FAQ: Best configurations for GPUGRID thread. You will just need to create a cc_config file and add a few lines. It will make some difference, but more for Fermi cards. I suggest you also consider reducing your cache and reporting tasks immediately.

Post to thread

Message boards : Graphics cards (GPUs) : 2 X GTX 260 (216 cores) suspending work - high CPU usage

//