Advanced search

Message boards : Graphics cards (GPUs) : Is that good performance? GTX 460

Author Message
ales.vanicky
Send message
Joined: 24 May 09
Posts: 7
Credit: 100,258,910
RAC: 0
Level
Cys
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwat
Message 24312 - Posted: 8 Apr 2012 | 15:19:01 UTC
Last modified: 8 Apr 2012 | 15:20:35 UTC

On this mashine Im crunching almost 24/7. Its W7 4GRAM GTX 460 (last drivers - I red about probs just now). I overclock it with MSI afterburner slightly just now, but also no difference... Thanx for any info.
On my second mashine Im crunching with the GTX 470 and the performance is 4 times higher, RAC litle bit over 100K.

frankhagen
Send message
Joined: 18 Sep 08
Posts: 65
Credit: 3,037,414
RAC: 0
Level
Ala
Scientific publications
watwatwatwatwat
Message 24313 - Posted: 8 Apr 2012 | 15:28:46 UTC - in response to Message 24312.

On this mashine Im crunching almost 24/7. Its W7 4GRAM GTX 460 (last drivers - I red about probs just now). I overclock it with MSI afterburner slightly just now, but also no difference... Thanx for any info.
On my second mashine Im crunching with the GTX 470 and the performance is 4 times higher, RAC litle bit over 100K.


you only got 50-60% GPU-load - why?

your athlon x2 is a pretty slow thing.

set boinc to use only 50% of CPU's

you got physix installed - you will not need it here, but it may interfere with crunching.

5pot
Send message
Joined: 8 Mar 12
Posts: 411
Credit: 2,083,882,218
RAC: 0
Level
Phe
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 24314 - Posted: 8 Apr 2012 | 16:17:38 UTC

PhysX can interfere w/ crunching?

ales.vanicky
Send message
Joined: 24 May 09
Posts: 7
Credit: 100,258,910
RAC: 0
Level
Cys
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwat
Message 24315 - Posted: 8 Apr 2012 | 16:35:05 UTC


you only got 50-60% GPU-load - why?

Thats what Im asking, on my previous OS - WinXP, with almost same HW, it run 99%


set boinc to use only 50% of CPU's

Why that? Im crunching Rosetta also.

you got physix installed - you will not need it here, but it may interfere with crunching.

Done and no performance improvement...

Rantanplan
Send message
Joined: 22 Jul 11
Posts: 166
Credit: 138,629,987
RAC: 0
Level
Cys
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 24316 - Posted: 8 Apr 2012 | 16:46:36 UTC

I decided to stop Rosetta processing for a long time, funds are tiny an energy effort is gigantic for that amount of credit.

ales.vanicky
Send message
Joined: 24 May 09
Posts: 7
Credit: 100,258,910
RAC: 0
Level
Cys
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwat
Message 24317 - Posted: 8 Apr 2012 | 17:05:55 UTC - in response to Message 24316.
Last modified: 8 Apr 2012 | 17:10:53 UTC

I decided to stop Rosetta processing for a long time, funds are tiny an energy effort is gigantic for that amount of credit.

Yeah, understand, but in that case Im not crunching for credit... Has this big effect on GPU performance?

Profile skgiven
Volunteer moderator
Volunteer tester
Avatar
Send message
Joined: 23 Apr 09
Posts: 3968
Credit: 1,995,359,260
RAC: 0
Level
His
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 24320 - Posted: 8 Apr 2012 | 18:28:56 UTC - in response to Message 24317.

At best a GTX 460 could get ~half the credit of a GTX 470 here; cc2.1 vs cc2.0 (better).
If you run short and long tasks you will a mix of different bonuses.
Having a large cache (for here) further impacts on credit.
Failures obviously don't help either, especially mid-run fails.

Your OC (+27%) is probably a bit too high and is causing the failures, although your 295.73 driver is a known bad driver for W7. W7 is also known to be 11%+ slower than XP.
Your fan speed is asking for trouble, 40% and might also explain why you are getting failures - While 71degC isn't bad, ~60deg should be readily possible for that card, especially if 40% fan speed => 71degC.

If your CPU tasks consume 100% of the CPU processing capability that leaves nothing for the GPU. In reality the GPU would have to contend for CPU usage when required. Obviously if the GPU has to wait for the CPU to become free in order to process something on the CPU (even if it takes <1ms) before returning to GPU processing (repeat many times over tens of thousands of seconds) then GPU performance will suffer. To what extent depends on the specific task being run; some GPUGrid tasks such as Ignasi's presently have to do more processing on the CPU, while other tasks such as Paola's (AFAIK) use less CPU resources.

The FAQ's cover most of this.
____________
FAQ's

HOW TO:
- Opt out of Beta Tests
- Ask for Help

Rantanplan
Send message
Joined: 22 Jul 11
Posts: 166
Credit: 138,629,987
RAC: 0
Level
Cys
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 24321 - Posted: 8 Apr 2012 | 18:49:51 UTC
Last modified: 8 Apr 2012 | 18:50:26 UTC

http://www.gpugrid.net/forum_thread.php?id=2707

Strange thing, i incresed my gpu usage by overclocking the pcie frequency,

getting 5-10%, but results at this time are not save.

You can try if u will set to 105 Mhz on PCIe frequency, by your own risk.

using two GTX 460 gpus on same board.

ales.vanicky
Send message
Joined: 24 May 09
Posts: 7
Credit: 100,258,910
RAC: 0
Level
Cys
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwat
Message 24322 - Posted: 8 Apr 2012 | 19:51:43 UTC


Your OC (+27%) is probably a bit too high and is causing the failures,

I overclocked it just today, so failures in my account http://www.gpugrid.net/results.php?userid=25243 are not caused by OC.


Your fan speed is asking for trouble, 40% and might also explain why you are getting failures - While 71degC isn't bad, ~60deg should be readily possible for that card, especially if 40% fan speed => 71degC.

Fan speed is set automatically. What I can do here (besides set it manually)?

If your CPU tasks consume 100% of the CPU processing capability that leaves nothing for the GPU. In reality the GPU would have to contend for CPU usage when required. Obviously if the GPU has to wait for the CPU to become free in order to process something on the CPU (even if it takes <1ms) before returning to GPU processing (repeat many times over tens of thousands of seconds) then GPU performance will suffer. To what extent depends on the specific task being run; some GPUGrid tasks such as Ignasi's presently have to do more processing on the CPU, while other tasks such as Paola's (AFAIK) use less CPU resources.

The FAQ's cover most of this.

Now I tried pause Rosetta and leave all cpu for GPUGRID, but no improvements

frankhagen
Send message
Joined: 18 Sep 08
Posts: 65
Credit: 3,037,414
RAC: 0
Level
Ala
Scientific publications
watwatwatwatwat
Message 24323 - Posted: 8 Apr 2012 | 20:53:44 UTC - in response to Message 24322.

Fan speed is set automatically. What I can do here (besides set it manually)?


OMFG!

you are running MSI-afterbruner?

so you can control the fan speed manually - or even set up your own profile.

don't get me wrong - i'm not running GPUgrid for a long time now, i've been there when it was PS3grid - running a GT-9600 powered by a P4. :)

but the knowledge still stands - if your CPU is not feeding fast enough, the GPU definitely will starve.

Rantanplan
Send message
Joined: 22 Jul 11
Posts: 166
Credit: 138,629,987
RAC: 0
Level
Cys
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 24324 - Posted: 8 Apr 2012 | 23:22:43 UTC

ok, absolutly no zero advantage by overclocking pcie bus frequency, what a mistake.

i change clockings immediatly.

Profile dskagcommunity
Avatar
Send message
Joined: 28 Apr 11
Posts: 456
Credit: 817,790,789
RAC: 0
Level
Glu
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 24326 - Posted: 9 Apr 2012 | 1:25:29 UTC - in response to Message 24313.
Last modified: 9 Apr 2012 | 1:26:15 UTC

On this mashine Im crunching almost 24/7. Its W7 4GRAM GTX 460 (last drivers - I red about probs just now). I overclock it with MSI afterburner slightly just now, but also no difference... Thanx for any info.
On my second mashine Im crunching with the GTX 470 and the performance is 4 times higher, RAC litle bit over 100K.


you only got 50-60% GPU-load - why?

your athlon x2 is a pretty slow thing.

set boinc to use only 50% of CPU's

you got physix installed - you will not need it here, but it may interfere with crunching.


The x2 Its much faster then one of my pentium4with 285gtx ;) and i get 99% ;) but im with you hold a core free for this fax4 units (and really its only needed there, i uses the full p4 core for wcg before fax4 with 99% too) they consume some cpu power too. I think its that w7 thing. In another thread there was already a discussion that linux and close to that xp are the fastes os. And then anytime comes w7 with much difference.
____________
DSKAG Austria Research Team: http://www.research.dskag.at



Crunching for my deceased Dog who had "good" Braincancer..

Profile skgiven
Volunteer moderator
Volunteer tester
Avatar
Send message
Joined: 23 Apr 09
Posts: 3968
Credit: 1,995,359,260
RAC: 0
Level
His
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 24327 - Posted: 9 Apr 2012 | 6:29:10 UTC - in response to Message 24326.

Do Not OC the PCIE via FSB!
____________
FAQ's

HOW TO:
- Opt out of Beta Tests
- Ask for Help

ales.vanicky
Send message
Joined: 24 May 09
Posts: 7
Credit: 100,258,910
RAC: 0
Level
Cys
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwat
Message 24328 - Posted: 9 Apr 2012 | 11:33:25 UTC
Last modified: 9 Apr 2012 | 11:37:57 UTC

OK, I understand it may be the W7 thing. I have 0.44 CPUs + 1.00 NVIDIA GPUs usage not depending on swan_sync=0 or stopping the rosetta. But strange thing is, my other machine with XP has almost the same usage (0.46 CPUs + 1.00 NVIDIA GPUs) and GPU usage on some 68%! Im using latest BOINC manager: 6.12.34, ndvidia drivers on W7 machine 295.73 (and 285.58 on W XP)

frankhagen
Send message
Joined: 18 Sep 08
Posts: 65
Credit: 3,037,414
RAC: 0
Level
Ala
Scientific publications
watwatwatwatwat
Message 24329 - Posted: 9 Apr 2012 | 11:45:41 UTC - in response to Message 24328.

OK, I understand it may be the W7 thing. I have 0.44 CPUs + 1.00 NVIDIA GPUs usage not depending on swan_sync=0 or stopping the rosetta. But strange thing is, my other machine with XP has almost the same usage (0.46 CPUs + 1.00 NVIDIA GPUs) and GPU usage on some 68%! Im using latest BOINC manager: 6.12.34, ndvidia drivers on W7 machine 295.73 (and 285.58 on W XP)


THAT's only what boinc assumes to be the case - nothing real in there.

Post to thread

Message boards : Graphics cards (GPUs) : Is that good performance? GTX 460

//