Advanced search

Message boards : Server and website : Unable to contact server

Author Message
curiously_indifferent
Send message
Joined: 20 Nov 17
Posts: 16
Credit: 665,880,599
RAC: 153,122
Level
Lys
Scientific publications
watwatwat
Message 57507 - Posted: 6 Oct 2021 | 16:23:20 UTC

Does anyone else have a problem accessing the server? I get the following messages:

Fetching schedule list
Project communication failed: attempting access to reference site
Internet access ok - project servers may be temporarily down

This has been going on for about a week. Updating or Resetting the project generates the same message. Other projects seem to be fine.

I did change the certificate file yesterday, but that does not seem to have made a difference.

Running Win10Pro with a Nvidia 2060 GPU. The OS Version is 10.0.19043 Build 19043 and the GPU Driver is 30.0.14.7196

The last WU I received was Sept 29.

Profile JStateson
Avatar
Send message
Joined: 31 Oct 08
Posts: 183
Credit: 3,283,714,822
RAC: 143,169
Level
Arg
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 57508 - Posted: 6 Oct 2021 | 17:07:13 UTC - in response to Message 57507.


I did change the certificate file yesterday, but that does not seem to have made a difference.



Did the error message go away when you restarted Boinc?

I just got three of 2.18 tasks in a few miinutes ago I actually saw the server status go from 64 down to 61. I had checked status before and after allowing new work.

curiously_indifferent
Send message
Joined: 20 Nov 17
Posts: 16
Credit: 665,880,599
RAC: 153,122
Level
Lys
Scientific publications
watwatwat
Message 57509 - Posted: 6 Oct 2021 | 17:28:14 UTC - in response to Message 57508.

Still get the message after restarting BONIC.

Profile JStateson
Avatar
Send message
Joined: 31 Oct 08
Posts: 183
Credit: 3,283,714,822
RAC: 143,169
Level
Arg
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 57510 - Posted: 6 Oct 2021 | 17:38:50 UTC - in response to Message 57509.
Last modified: 6 Oct 2021 | 17:41:18 UTC

Still get the message after restarting BONIC.


Not sure where or if you got the corrected file or maybe it was put in the wrong place.

browse to \Program Files\Boinc and look at ca-bundle.crt
it should have a date from october something like this

10/03/2021 12:24 PM 225,584 ca-bundle.crt

If not october then you probably still have the file with the expired certificate

Open the file with notepad and search for the phrase
DST Root CA X3

If there then select that certificate and delete it.
save the file and restart boinc.

curiously_indifferent
Send message
Joined: 20 Nov 17
Posts: 16
Credit: 665,880,599
RAC: 153,122
Level
Lys
Scientific publications
watwatwat
Message 57512 - Posted: 6 Oct 2021 | 17:48:12 UTC - in response to Message 57510.

I added the new ca-bundle.crt file yesterday and DST Root CA X3 has ben deleted.

Haven't ben able to contact the server with this change.

Profile JStateson
Avatar
Send message
Joined: 31 Oct 08
Posts: 183
Credit: 3,283,714,822
RAC: 143,169
Level
Arg
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 57514 - Posted: 6 Oct 2021 | 17:52:10 UTC - in response to Message 57512.

Still get the message after restarting BONIC..


You state you are still getting the error message

I assumed you meant the error message about the expired certificate

What error message did you mean?

curiously_indifferent
Send message
Joined: 20 Nov 17
Posts: 16
Credit: 665,880,599
RAC: 153,122
Level
Lys
Scientific publications
watwatwat
Message 57515 - Posted: 6 Oct 2021 | 18:01:02 UTC - in response to Message 57507.

This is the error message I am referring to:



Fetching schedule list
Project communication failed: attempting access to reference site
Internet access ok - project servers may be temporarily down



I started getting the messages about a week ago. Updating the ca-bundle.crt file, and restarting BONIC or the PC, does not fix this issue.

Keith Myers
Send message
Joined: 13 Dec 17
Posts: 808
Credit: 1,077,149,831
RAC: 985,453
Level
Met
Scientific publications
watwatwatwatwat
Message 57516 - Posted: 6 Oct 2021 | 18:15:56 UTC - in response to Message 57515.

You've got a cache somewhere fouling things up.

Richard Haselgrove
Send message
Joined: 11 Jul 09
Posts: 1245
Credit: 3,344,411,168
RAC: 867,709
Level
Arg
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 57517 - Posted: 6 Oct 2021 | 18:38:51 UTC - in response to Message 57515.

I started getting the messages about a week ago. Updating the ca-bundle.crt file, and restarting BONIC or the PC, does not fix this issue.

Updating ca-bundle.crt should do it - the symptoms and the timing are right for the certificate expiry problem.

Can you verify that you have exactly the right file, and that you've put it in exactly the right place? Where did you get the file from? It should have a timestamp of 30 September 2021 or later.

curiously_indifferent
Send message
Joined: 20 Nov 17
Posts: 16
Credit: 665,880,599
RAC: 153,122
Level
Lys
Scientific publications
watwatwat
Message 57518 - Posted: 6 Oct 2021 | 18:51:47 UTC - in response to Message 57517.

I used these links to get the new ca-bundle.crt file:

https://www.gpugrid.net/forum_thread.php?id=5256&nowrap=true#57440

When I open the file, using notepad, I can see the DST Root CA X3 section has been deleted.

The new/updated ca-bundle.crt file is in the same folder as the previous ca-bundle.crt file. I renamed the old ca-bundle.crt file .old

Profile JStateson
Avatar
Send message
Joined: 31 Oct 08
Posts: 183
Credit: 3,283,714,822
RAC: 143,169
Level
Arg
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 57520 - Posted: 6 Oct 2021 | 19:20:58 UTC - in response to Message 57518.
Last modified: 6 Oct 2021 | 19:28:36 UTC

I used these links to get the new ca-bundle.crt file:

https://www.gpugrid.net/forum_thread.php?id=5256&nowrap=true#57440

When I open the file, using notepad, I can see the DST Root CA X3 section has been deleted.

The new/updated ca-bundle.crt file is in the same folder as the previous ca-bundle.crt file. I renamed the old ca-bundle.crt file .old



All that should have worked. Not sure what the problem is since a reboot should have worked.

The reference site is either Google or Ibm and they responded according to that message

All I can suggest is

1. Try pinging the project

C:\Users\josep>ping www.gpugrid.net

Pinging www.gpugrid.net [84.89.134.145] with 32 bytes of data:
Reply from 84.89.134.145: bytes=32 time=170ms TTL=44
Reply from 84.89.134.145: bytes=32 time=170ms TTL=44
Reply from 84.89.134.145: bytes=32 time=170ms TTL=44
Reply from 84.89.134.145: bytes=32 time=170ms TTL=44


2. Look in the windows 10 event viewer (system) for unusual errors such as "schannel" or anything related to ssl.

Sorry

Richard Haselgrove
Send message
Joined: 11 Jul 09
Posts: 1245
Credit: 3,344,411,168
RAC: 867,709
Level
Arg
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 57521 - Posted: 6 Oct 2021 | 19:24:55 UTC - in response to Message 57518.

That's strange - it might be something else.

The acid test: go to BOINC Manager, Advanced view.
Select Options menu, click 'Event Log Options...'
On the form that opens, tick the box labelled http_debug (don't change any others)
Click Save.

Go to the projects tab. Highlight GPUGrid, click Update once.

Wait no more than about 5 seconds, go back to the Event Log Options menu, remove the http_debug tick, save.

Then look at the event log itself. http_debug puts out a lot of detail - depending on your computer experience, it may or may not mean anything to you. See if you can pick out any references to certificates and expiry.

If not, select and copy the whole segment from 'Starting scheduler request' to 'Scheduler request completed' (or failed - depending what happened). Post the whole thing here, and we'll go through it for you.

curiously_indifferent
Send message
Joined: 20 Nov 17
Posts: 16
Credit: 665,880,599
RAC: 153,122
Level
Lys
Scientific publications
watwatwat
Message 57522 - Posted: 6 Oct 2021 | 20:00:26 UTC - in response to Message 57521.

I am not computer literate enough to understand most of what is going on here, but I do see a SSL certificate problem and Peer certificate problem.

Should I delete the old ca-bundle.crt file?. Any other suggestions?



10/6/2021 3:54:09 PM | GPUGRID | update requested by user
10/6/2021 3:54:10 PM | | [http] HTTP_OP::init_get(): https://www.gpugrid.net/notices.php?userid=514725&auth=514725_4639989f215f6bf6d86c314204201c59
10/6/2021 3:54:10 PM | | [http] HTTP_OP::libcurl_exec(): ca-bundle set
10/6/2021 3:54:10 PM | GPUGRID | [http] HTTP_OP::init_get(): https://www.gpugrid.net/
10/6/2021 3:54:10 PM | GPUGRID | [http] HTTP_OP::libcurl_exec(): ca-bundle set
10/6/2021 3:54:10 PM | GPUGRID | Fetching scheduler list
10/6/2021 3:54:11 PM | | [http] [ID#0] Info: Connection 376 seems to be dead!
10/6/2021 3:54:11 PM | | [http] [ID#0] Info: Closing connection 376
10/6/2021 3:54:11 PM | GPUGRID | [http] [ID#1] Info: Found bundle for host www.gpugrid.net: 0x264eb00 [serially]
10/6/2021 3:54:11 PM | | [http] [ID#0] Info: Trying 84.89.134.145...
10/6/2021 3:54:11 PM | GPUGRID | [http] [ID#1] Info: Hostname was found in DNS cache
10/6/2021 3:54:11 PM | GPUGRID | [http] [ID#1] Info: Trying 84.89.134.145...
10/6/2021 3:54:11 PM | | [http] [ID#0] Info: Connected to www.gpugrid.net (84.89.134.145) port 443 (#380)
10/6/2021 3:54:11 PM | | [http] [ID#0] Info: ALPN, offering http/1.1
10/6/2021 3:54:11 PM | | [http] [ID#0] Info: Cipher selection: ALL:!EXPORT:!EXPORT40:!EXPORT56:!aNULL:!LOW:!RC4:@STRENGTH
10/6/2021 3:54:11 PM | | [http] [ID#0] Info: successfully set certificate verify locations:
10/6/2021 3:54:11 PM | | [http] [ID#0] Info: CAfile: D:\Program Files\ca-bundle.crt
10/6/2021 3:54:11 PM | | [http] [ID#0] Info: CApath: none
10/6/2021 3:54:11 PM | | [http] [ID#0] Info: TLSv1.2 (OUT), TLS header, Certificate Status (22):
10/6/2021 3:54:11 PM | | [http] [ID#0] Info: TLSv1.2 (OUT), TLS handshake, Client hello (1):
10/6/2021 3:54:11 PM | GPUGRID | [http] [ID#1] Info: Connected to www.gpugrid.net (84.89.134.145) port 443 (#381)
10/6/2021 3:54:11 PM | GPUGRID | [http] [ID#1] Info: ALPN, offering http/1.1
10/6/2021 3:54:11 PM | GPUGRID | [http] [ID#1] Info: Cipher selection: ALL:!EXPORT:!EXPORT40:!EXPORT56:!aNULL:!LOW:!RC4:@STRENGTH
10/6/2021 3:54:11 PM | GPUGRID | [http] [ID#1] Info: successfully set certificate verify locations:
10/6/2021 3:54:11 PM | GPUGRID | [http] [ID#1] Info: CAfile: D:\Program Files\ca-bundle.crt
10/6/2021 3:54:11 PM | GPUGRID | [http] [ID#1] Info: CApath: none
10/6/2021 3:54:11 PM | GPUGRID | [http] [ID#1] Info: TLSv1.2 (OUT), TLS header, Certificate Status (22):
10/6/2021 3:54:11 PM | GPUGRID | [http] [ID#1] Info: TLSv1.2 (OUT), TLS handshake, Client hello (1):
10/6/2021 3:54:11 PM | | [http] [ID#0] Info: TLSv1.2 (IN), TLS handshake, Server hello (2):
10/6/2021 3:54:11 PM | | [http] [ID#0] Info: TLSv1.2 (IN), TLS handshake, Certificate (11):
10/6/2021 3:54:11 PM | | [http] [ID#0] Info: TLSv1.2 (OUT), TLS alert, Server hello (2):
10/6/2021 3:54:11 PM | | [http] [ID#0] Info: SSL certificate problem: certificate has expired
10/6/2021 3:54:11 PM | | [http] [ID#0] Info: Closing connection 380
10/6/2021 3:54:11 PM | | [http] HTTP error: Peer certificate cannot be authenticated with given CA certificates
10/6/2021 3:54:12 PM | GPUGRID | [http] [ID#1] Info: TLSv1.2 (IN), TLS handshake, Server hello (2):
10/6/2021 3:54:12 PM | GPUGRID | [http] [ID#1] Info: TLSv1.2 (IN), TLS handshake, Certificate (11):
10/6/2021 3:54:12 PM | GPUGRID | [http] [ID#1] Info: TLSv1.2 (OUT), TLS alert, Server hello (2):
10/6/2021 3:54:12 PM | GPUGRID | [http] [ID#1] Info: SSL certificate problem: certificate has expired
10/6/2021 3:54:12 PM | GPUGRID | [http] [ID#1] Info: Closing connection 381
10/6/2021 3:54:12 PM | GPUGRID | [http] HTTP error: Peer certificate cannot be authenticated with given CA certificates
10/6/2021 3:54:13 PM | | Project communication failed: attempting access to reference site
10/6/2021 3:54:13 PM | | [http] HTTP_OP::init_get(): https://www.google.com/
10/6/2021 3:54:13 PM | | [http] HTTP_OP::libcurl_exec(): ca-bundle set
10/6/2021 3:54:14 PM | | [http] [ID#0] Info: Found bundle for host www.google.com: 0x32a1d80 [can pipeline]
10/6/2021 3:54:14 PM | | [http] [ID#0] Info: Re-using existing connection! (#369) with host www.google.com
10/6/2021 3:54:14 PM | | [http] [ID#0] Info: Connected to www.google.com (172.217.1.196) port 443 (#369)
10/6/2021 3:54:14 PM | | [http] [ID#0] Sent header to server: GET / HTTP/1.1
10/6/2021 3:54:14 PM | | [http] [ID#0] Sent header to server: Host: www.google.com
10/6/2021 3:54:14 PM | | [http] [ID#0] Sent header to server: User-Agent: BOINC client (windows_x86_64 7.16.11)
10/6/2021 3:54:14 PM | | [http] [ID#0] Sent header to server: Accept: */*
10/6/2021 3:54:14 PM | | [http] [ID#0] Sent header to server: Accept-Encoding: deflate, gzip
10/6/2021 3:54:14 PM | | [http] [ID#0] Sent header to server: Accept-Language: en_US
10/6/2021 3:54:14 PM | | [http] [ID#0] Sent header to server:
10/6/2021 3:54:14 PM | | [http] [ID#0] Received header from server: HTTP/1.1 200 OK
10/6/2021 3:54:14 PM | | [http] [ID#0] Received header from server: Date: Wed, 06 Oct 2021 19:54:15 GMT
10/6/2021 3:54:14 PM | | [http] [ID#0] Received header from server: Expires: -1
10/6/2021 3:54:14 PM | | [http] [ID#0] Received header from server: Cache-Control: private, max-age=0
10/6/2021 3:54:14 PM | | [http] [ID#0] Received header from server: Content-Type: text/html; charset=ISO-8859-1
10/6/2021 3:54:14 PM | | [http] [ID#0] Received header from server: P3P: CP="This is not a P3P policy! See g.co/p3phelp for more info."
10/6/2021 3:54:14 PM | | [http] [ID#0] Received header from server: Content-Encoding: gzip
10/6/2021 3:54:14 PM | | [http] [ID#0] Received header from server: Server: gws
10/6/2021 3:54:14 PM | | [http] [ID#0] Received header from server: X-XSS-Protection: 0
10/6/2021 3:54:14 PM | | [http] [ID#0] Received header from server: X-Frame-Options: SAMEORIGIN
10/6/2021 3:54:14 PM | | [http] [ID#0] Received header from server: Set-Cookie: 1P_JAR=2021-10-06-19; expires=Fri, 05-Nov-2021 19:54:15 GMT; path=/; domain=.google.com; Secure
10/6/2021 3:54:14 PM | | [http] [ID#0] Received header from server: Set-Cookie: NID=511=d2F-ZgkxtOU1UTrqZ2t_4I-qkWJoIxMzbEV0f14cU66ZWyyE0kyurGXHwq_GGzddg911wyEkkB0hZ5_tMIS-4ZDeaa-uIDdIfHZCOIWmWXGo4i5nSWNF7bczpA5u8wWoRFAawi_mlVtFlcJp-sRX4JZ1bRV56a4mJ1-ZrTBoed8; expires=Thu, 07-Apr-2022 19:54:15 GMT; path=/; domain=.google.com; HttpOnly
10/6/2021 3:54:14 PM | | [http] [ID#0] Received header from server: Alt-Svc: h3=":443"; ma=2592000,h3-29=":443"; ma=2592000,h3-T051=":443"; ma=2592000,h3-Q050=":443"; ma=2592000,h3-Q046=":443"; ma=2592000,h3-Q043=":443"; ma=2592000,quic=":443"; ma=2592000; v="46,43"
10/6/2021 3:54:14 PM | | [http] [ID#0] Received header from server: Transfer-Encoding: chunked
10/6/2021 3:54:14 PM | | [http] [ID#0] Received header from server:
10/6/2021 3:54:14 PM | | [http] [ID#0] Received header from server: 00000001
10/6/2021 3:54:14 PM | | [http] [ID#0] Received header from server: 
10/6/2021 3:54:14 PM | | [http] [ID#0] Received header from server: 00000001
10/6/2021 3:54:14 PM | |
10/6/2021 3:54:14 PM | | [http] [ID#0] Received header from server: 00000001
10/6/2021 3:54:14 PM | | [http] [ID#0] Received header from server: 
10/6/2021 3:54:14 PM | | [http] [ID#0] Received header from server: 00000001
10/6/2021 3:54:15 PM | | [http] [ID#0] Info: Connection #369 to host www.google.com left intact
10/6/2021 3:54:15 PM | | Internet access OK - project servers may be temporarily down.
10/6/2021 3:54:23 PM | | Re-reading cc_config.xml
10/6/2021 3:54:23 PM | | log flags: file_xfer, sched_ops, task
10/6/2021 3:54:23 PM | Asteroids@home | Found app_config.xml
10/6/2021 3:54:23 PM | Einstein@Home | Found app_config.xml
10/6/2021 3:54:23 PM | GPUGRID | Found app_config.xml
10/6/2021 3:54:23 PM | GPUGRID | Your app_config.xml file refers to an unknown application 'acemd3'. Known applications: None
10/6/2021 3:54:23 PM | Milkyway@Home | Found app_config.xml
10/6/2021 3:54:23 PM | World Community Grid | Found app_config.xml
10/6/2021 3:54:23 PM | World Community Grid | Your app_config.xml file refers to an unknown application 'opng'. Known applications: 'arp1', 'mcm1', 'mip1', 'opn1'

curiously_indifferent
Send message
Joined: 20 Nov 17
Posts: 16
Credit: 665,880,599
RAC: 153,122
Level
Lys
Scientific publications
watwatwat
Message 57523 - Posted: 6 Oct 2021 | 20:06:30 UTC - in response to Message 57520.

I don't know how to post screenshots apparently, but pinging www.gpugrid.net resulted in 4 packets being sent and four packets received. The Event Viewer (System) only showed Information entries, no Errors.

Profile JStateson
Avatar
Send message
Joined: 31 Oct 08
Posts: 183
Credit: 3,283,714,822
RAC: 143,169
Level
Arg
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 57524 - Posted: 6 Oct 2021 | 20:52:46 UTC
Last modified: 6 Oct 2021 | 21:11:39 UTC

I suspect you have things in the wrong place or I dont understand the listing


10/6/2021 3:54:11 PM | GPUGRID | [http] [ID#1] Info: CAfile: D:\Program Files\ca-bundle.crt


that file should be in \Program Files\Boinc

next to the other executables

You should have at d:\Program Files\boinc
or at
c:\Program Files\boinc

the following
ca-bundle.crt
and ca-bundle.crt_old

if I understand correctly

Boinc is clearly getting the wrong ca-bundle as your script is exactly what I would see with the wrong bundle

Keith Myers
Send message
Joined: 13 Dec 17
Posts: 808
Credit: 1,077,149,831
RAC: 985,453
Level
Met
Scientific publications
watwatwatwatwat
Message 57525 - Posted: 6 Oct 2021 | 20:52:53 UTC

I would delete the old file. BOINC may still be caching it.

curiously_indifferent
Send message
Joined: 20 Nov 17
Posts: 16
Credit: 665,880,599
RAC: 153,122
Level
Lys
Scientific publications
watwatwat
Message 57526 - Posted: 6 Oct 2021 | 20:58:03 UTC - in response to Message 57524.

Not sure why it is showing that. The file is in D:\Program Files\BONIC

Profile JStateson
Avatar
Send message
Joined: 31 Oct 08
Posts: 183
Credit: 3,283,714,822
RAC: 143,169
Level
Arg
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 57527 - Posted: 6 Oct 2021 | 20:58:17 UTC - in response to Message 57525.
Last modified: 6 Oct 2021 | 21:01:50 UTC

I would delete the old file. BOINC may still be caching it.


Supposedly the system rebooted.

Possibly, if the file is missing, a windows path search may find a zillion ca-bundles and pick the first one!

Profile JStateson
Avatar
Send message
Joined: 31 Oct 08
Posts: 183
Credit: 3,283,714,822
RAC: 143,169
Level
Arg
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 57528 - Posted: 6 Oct 2021 | 21:00:29 UTC - in response to Message 57526.
Last modified: 6 Oct 2021 | 21:05:07 UTC

Not sure why it is showing that. The file is in D:\Program Files\BONIC


Don't think that is correct spelling

Note that if you use notepad to save "ca-bundle.crt" you might unwittingly end up with "ca-bundle.txt" which won't work. Been there done that myself

curiously_indifferent
Send message
Joined: 20 Nov 17
Posts: 16
Credit: 665,880,599
RAC: 153,122
Level
Lys
Scientific publications
watwatwat
Message 57529 - Posted: 6 Oct 2021 | 21:10:49 UTC - in response to Message 57528.

LHC, WCG, Milky Way, Einstein, Cosmology, Rosetta are working fine.

GPUGrid and CPDN seem to be having the same issue.

Asteroids and Universe are not working, but I think they are both unrelated server issues.

I deleted the old ca-bundle.crt files and the problem still exists.

Regarding saving the ca-bundle.crt file in notepad, which encoding should be used?

Thanks for everyone's help!

Profile JStateson
Avatar
Send message
Joined: 31 Oct 08
Posts: 183
Credit: 3,283,714,822
RAC: 143,169
Level
Arg
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 57530 - Posted: 6 Oct 2021 | 21:15:25 UTC - in response to Message 57529.
Last modified: 6 Oct 2021 | 21:18:41 UTC

LHC, WCG, Milky Way, Einstein, Cosmology, Rosetta are working fine.


They do not check stuff like this project does or so I have read.

I assume you downloaded the correct file as listed by Keith.
From reading your listing, that file was put at d:\Program Files\
it should have been put at d:\Program Files\boinc

just move that file into the proper folder and restart boinc

[edit]
From the command prompt do a file compare to verify the missing old cert

fc ca-bundle.crt ca-bundle.crt_old

Richard Haselgrove
Send message
Joined: 11 Jul 09
Posts: 1245
Credit: 3,344,411,168
RAC: 867,709
Level
Arg
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 57531 - Posted: 6 Oct 2021 | 21:16:08 UTC

There's a line

10/6/2021 3:54:11 PM | | [http] [ID#0] Info: SSL certificate problem: certificate has expired

which conforms that BOINC (note spelling) is still using the old ca-bundle.crt file. I don't buy the 'cached' explanation: the 'path' explanation is possible, but unlikely.

Richard Haselgrove
Send message
Joined: 11 Jul 09
Posts: 1245
Credit: 3,344,411,168
RAC: 867,709
Level
Arg
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 57532 - Posted: 6 Oct 2021 | 21:25:51 UTC - in response to Message 57530.

LHC, WCG, Milky Way, Einstein, Cosmology, Rosetta are working fine.

They do not check stuff like this project does or so I have read.

Yes they do, but they use certificates from a different supplier - and they're still working.

But the file location definitely needs sorting out.

curiously_indifferent
Send message
Joined: 20 Nov 17
Posts: 16
Credit: 665,880,599
RAC: 153,122
Level
Lys
Scientific publications
watwatwat
Message 57533 - Posted: 6 Oct 2021 | 21:51:46 UTC - in response to Message 57532.

Problem resolved.

I had replaced the ca-bundle.crt file in D:\Program Files\BOINC, but I missed replacing it in D:\Program Files

After replacing ca-bundle.crt, in D:\Program Files, everything is fine now.

Apologies for messing this up and thanks for the help.

Post to thread

Message boards : Server and website : Unable to contact server