Advanced search

Message boards : Number crunching : Boinc 64-Bit Version uses only 45-50 % GPU

Author Message
Rantanplan
Send message
Joined: 22 Jul 11
Posts: 166
Credit: 138,629,987
RAC: 0
Level
Cys
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22370 - Posted: 26 Oct 2011 | 20:07:39 UTC

Hello is that normal ?

When it wont change i will stop the use of the

64-Bit Version and continue under Windows XP.


Profile Carlesa25
Avatar
Send message
Joined: 13 Nov 10
Posts: 328
Credit: 72,619,453
RAC: 0
Level
Thr
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22374 - Posted: 26 Oct 2011 | 21:59:02 UTC - in response to Message 22370.

Hello: Using both 64-bit Boinc, Linux-Ubuntu 11.10 and Windows 7 (all 64bit) and it works perfectly with a load of up to 85% on the GPU.

It would make clear to which it refers, has changed the OS (which Windows. ...?) and BOINC or both, you changed the configuration of Boinc? .... etc. Greetings.

Profile K1atOdessa
Send message
Joined: 25 Feb 08
Posts: 249
Credit: 370,320,941
RAC: 0
Level
Asp
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22375 - Posted: 26 Oct 2011 | 23:07:14 UTC

I was just thinking the same thing, but for another type of GPU. I have a GTX 570, which uses anywhere from 45-65%. I don't think I've ever seen it go into the 70's. I know Windows 7 (x64 is what I use) won't let you get to near 100%, but I figured it would be higher than 50% on average(it was often in the 80's on the older tasks for my 8800GT, but for a different app from the project).

I have BOINC 6.10.36 as recommended on the home page. Any options I use or tweaks to Windows I should make to increase to the 70's or 80's?

Profile skgiven
Volunteer moderator
Volunteer tester
Avatar
Send message
Joined: 23 Apr 09
Posts: 3968
Credit: 1,995,359,260
RAC: 0
Level
His
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22376 - Posted: 26 Oct 2011 | 23:11:32 UTC - in response to Message 22374.

45 to 50% is not normal, even under W7.
Perhaps this is another 285.62 problem (already experienced by another user).

Profile K1atOdessa
Send message
Joined: 25 Feb 08
Posts: 249
Credit: 370,320,941
RAC: 0
Level
Asp
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22382 - Posted: 27 Oct 2011 | 3:49:08 UTC - in response to Message 22376.

I am using drivers 266.58. What is the recommended version I should try to obtain better utilization?

Profile Carlesa25
Avatar
Send message
Joined: 13 Nov 10
Posts: 328
Credit: 72,619,453
RAC: 0
Level
Thr
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22387 - Posted: 27 Oct 2011 | 10:15:32 UTC - in response to Message 22382.

I am using drivers 266.58. What is the recommended version I should try to obtain better utilization?


Hi: In Windows 7 (64bits) I'm using 285.62 WHQL no problem with the GPU load of 80-85%. GTX 295.
Possibly the low use of the GPU is a question of the power saving settings in Windows, check it at peak performance. Greetings.

MarkJ
Volunteer moderator
Volunteer tester
Send message
Joined: 24 Dec 08
Posts: 738
Credit: 200,909,904
RAC: 0
Level
Leu
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22388 - Posted: 27 Oct 2011 | 11:47:22 UTC

And make sure you leave a CPU core free (set % processor usage in boinc to something like 87.5 [assuming you have an 8 core machine]). Set the Swan_Sync environment variable as well.

This has the effect of polling the driver (which uses more cpu time) but the gpu doesn't spend as long waiting for data or instructions.
____________
BOINC blog

Rantanplan
Send message
Joined: 22 Jul 11
Posts: 166
Credit: 138,629,987
RAC: 0
Level
Cys
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22390 - Posted: 27 Oct 2011 | 17:19:42 UTC - in response to Message 22374.
Last modified: 27 Oct 2011 | 17:20:38 UTC

(which Windows. ...?)


Windows 7 64-bit, no service pack.

I will check peak performance. Thx

Rantanplan
Send message
Joined: 22 Jul 11
Posts: 166
Credit: 138,629,987
RAC: 0
Level
Cys
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22392 - Posted: 27 Oct 2011 | 18:21:56 UTC - in response to Message 22390.

peak performance

That was the key.

Now Windows looks ugly, but i got gpu at almost 100%.

Greetings

David A. Dutton [Top Gun]
Send message
Joined: 14 Oct 11
Posts: 4
Credit: 5,528,654
RAC: 0
Level
Ser
Scientific publications
watwatwatwatwatwatwatwat
Message 22393 - Posted: 27 Oct 2011 | 19:19:30 UTC - in response to Message 22392.
Last modified: 27 Oct 2011 | 19:20:10 UTC

(deleted)

Rantanplan
Send message
Joined: 22 Jul 11
Posts: 166
Credit: 138,629,987
RAC: 0
Level
Cys
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22394 - Posted: 27 Oct 2011 | 19:27:16 UTC - in response to Message 22392.
Last modified: 27 Oct 2011 | 19:29:44 UTC

peak performance

That was the key.

Now Windows looks ugly, but i got gpu at almost 100%.

Greetings


Naw , i did a mistake, it was Milkyway at 100%,

IBuch ACEM2 and GIANNI runs at almost 75% , also not bad.

Profile K1atOdessa
Send message
Joined: 25 Feb 08
Posts: 249
Credit: 370,320,941
RAC: 0
Level
Asp
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22397 - Posted: 28 Oct 2011 | 4:25:50 UTC

Updated driver to 280.26, now getting 75% consistently in the gpu utilization. Works for me.

I already had cpu usage at 99% (quad core) and the SWAN_SYNC option, so the updated driver apparently was key.

Rantanplan
Send message
Joined: 22 Jul 11
Posts: 166
Credit: 138,629,987
RAC: 0
Level
Cys
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22406 - Posted: 28 Oct 2011 | 18:23:01 UTC - in response to Message 22397.
Last modified: 28 Oct 2011 | 18:50:20 UTC

Back to the drop,

GIANNI Long Runs , back at 60% GPU Usage on the GTX460

IBUCH the same , 62% GPU usage

thats frustrating, i install old 280.26 video drivers and see.

Nothing has changed .

Try 275.33 drivers and see.

Rantanplan
Send message
Joined: 22 Jul 11
Posts: 166
Credit: 138,629,987
RAC: 0
Level
Cys
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22407 - Posted: 28 Oct 2011 | 19:31:54 UTC - in response to Message 22406.

with 275.33 IBUCH at 75 %,

try the recomended cuda drivers version 270.81 and see.

Profile Carlesa25
Avatar
Send message
Joined: 13 Nov 10
Posts: 328
Credit: 72,619,453
RAC: 0
Level
Thr
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22408 - Posted: 28 Oct 2011 | 20:14:29 UTC - in response to Message 22407.
Last modified: 28 Oct 2011 | 20:15:22 UTC

with 275.33 IBUCH at 75 %,

try the recomended cuda drivers version 270.81 and see.


Hello: First and advisable to install the latest NVIDIA drivers are 285.62 for Windows 7 that work perfectly.

The second, review the "Power Options" in Windows 7 (I guess you know how) and finally you can disable Aero for maximum performance, no more.

We assume that the card energy source, ventilation, temperature etc ... are correct. Greetings.

Rantanplan
Send message
Joined: 22 Jul 11
Posts: 166
Credit: 138,629,987
RAC: 0
Level
Cys
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22410 - Posted: 29 Oct 2011 | 6:41:44 UTC - in response to Message 22408.

So i tried it all, IBUCH ACED2 still at only 60 % GPU usage (load).

What a waste of time , the card doesnt can faster i think.

Profile K1atOdessa
Send message
Joined: 25 Feb 08
Posts: 249
Credit: 370,320,941
RAC: 0
Level
Asp
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22411 - Posted: 29 Oct 2011 | 12:41:06 UTC

With 285.62 drivers, IBUCH_PYRT running at only 41% utilization on my GTX570. Previous task, GIANNI_KKFREE, was running consistently at 65% utilization. Difference in task type? Going to keep an eye on it.

Rantanplan
Send message
Joined: 22 Jul 11
Posts: 166
Credit: 138,629,987
RAC: 0
Level
Cys
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22413 - Posted: 29 Oct 2011 | 14:15:07 UTC - in response to Message 22412.

And so the solution is stay on XP . Great.

Dagorath
Send message
Joined: 16 Mar 11
Posts: 509
Credit: 179,005,236
RAC: 0
Level
Ile
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22415 - Posted: 29 Oct 2011 | 22:07:52 UTC - in response to Message 22413.
Last modified: 29 Oct 2011 | 22:16:24 UTC

There is a better solution than XP. If you install Linux you will have higher GPU usage and faster run times. I know because I tried my GTX 570 on XP, Win7 and Linux. For GPUgrid and the current apps, Linux is best. If you make a dual-boot installation you can switch back to Windows just by rebooting, if the next version of the app runs faster on Windows.

Unless you run very specialized engineering apps that run only on Windows you will find Linux just as easy to use and more stable than Windows. If anybody wants to try Linux and needs help/advice/questions just let me know. I've used it for years and wouldn't go back to Windows even if Windows was free.

That's enough about Linux in this thread. If anybody wants further discussion of Linux then it might be test to start a new thread on that topic.

Profile Carlesa25
Avatar
Send message
Joined: 13 Nov 10
Posts: 328
Credit: 72,619,453
RAC: 0
Level
Thr
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 22417 - Posted: 29 Oct 2011 | 22:29:45 UTC - in response to Message 22415.
Last modified: 29 Oct 2011 | 22:31:19 UTC

Hello: I totally agree, I also use Windows 7 and Linux (Ubuntu 11.10) all 64bits. and Linux is best for these tasks, faster than any Windows. Greetings.

Post to thread

Message boards : Number crunching : Boinc 64-Bit Version uses only 45-50 % GPU

//