Advanced search

Message boards : Number crunching : No new work for cuda 4.2

Author Message
TJ
Send message
Joined: 26 Jun 09
Posts: 815
Credit: 1,470,385,294
RAC: 0
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28640 - Posted: 20 Feb 2013 | 18:56:29 UTC
Last modified: 20 Feb 2013 | 18:57:06 UTC

I have a GTX550Ti and according to skgiven this is better for cuda 4.2 than cuda 3.1 tasks. I can confirm that as a cuda 3.1 WU takes 41xxx seconds to complete.
So I have set to accept beta and cuda 4.2 short runs for this card, but however there is plenty of work according to the server page, I don't get any and there is another cruncher who gets no taks either.

How can this be solved?
Thanks.
____________
Greetings from TJ

TJ
Send message
Joined: 26 Jun 09
Posts: 815
Credit: 1,470,385,294
RAC: 0
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28646 - Posted: 20 Feb 2013 | 22:20:28 UTC

This machine with 550Ti and driver 306.97 can do cuda 4.2 as it did 2 beta's today that finished good and a third beta is in process.
So why not getting cuda 4.2 short runs?
____________
Greetings from TJ

flashawk
Send message
Joined: 18 Jun 12
Posts: 297
Credit: 3,572,627,986
RAC: 0
Level
Arg
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwat
Message 28647 - Posted: 20 Feb 2013 | 23:34:39 UTC
Last modified: 20 Feb 2013 | 23:42:22 UTC

If you're not getting the short 4.2 it's because there isn't any, the server status page is inaccurate.

Edit: I see you were told this already in another thread.

TJ
Send message
Joined: 26 Jun 09
Posts: 815
Credit: 1,470,385,294
RAC: 0
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28650 - Posted: 21 Feb 2013 | 15:00:17 UTC - in response to Message 28647.
Last modified: 21 Feb 2013 | 15:00:54 UTC

If you're not getting the short 4.2 it's because there isn't any, the server status page is inaccurate.


I don't belief this unless I hear it from a project member like Nathan of GDF.
Looking at the server status page several times a day, I see all numbers changing, so it is updating. And moreover Nathan mentioned that they had a whole lot new WU's.
____________
Greetings from TJ

Profile microchip
Avatar
Send message
Joined: 4 Sep 11
Posts: 110
Credit: 326,102,587
RAC: 0
Level
Asp
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28651 - Posted: 21 Feb 2013 | 15:09:46 UTC - in response to Message 28650.

If you're not getting the short 4.2 it's because there isn't any, the server status page is inaccurate.


I don't belief this unless I hear it from a project member like Nathan of GDF.
Looking at the server status page several times a day, I see all numbers changing, so it is updating. And moreover Nathan mentioned that they had a whole lot new WU's.


There must be something wrong with the short queue, then. Because I also don't get tasks from it and that's why I've enabled the long queue for now, which seems to work well.
____________

Team Belgium

TJ
Send message
Joined: 26 Jun 09
Posts: 815
Credit: 1,470,385,294
RAC: 0
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28653 - Posted: 21 Feb 2013 | 16:01:07 UTC
Last modified: 21 Feb 2013 | 16:01:41 UTC

I have updated to the latest nVidia driver 314.07, cuda version 5000 for the GTX550Ti.
And guess what happened, I got a: Short runs (2-3 hour on fastest card) 6.52 (cuda42)

So it seems a driver issue after all then...?

I will see how long it takes to complete, estimated 12:32 hours. It is now finishing Einstein@home (they take 35 minutes while BOINC continuously estimate 1hour and 50 minutes).

@microchip, if you can check which driver you are using on the pc that is not getting cuda42 tasks, and is the same as I had before (306.97) then we are pretty sure it's a driver thing. Thanks for your help.
Your statement that you didn't got these tasks either, convinced me to update my drivers.
____________
Greetings from TJ

Profile microchip
Avatar
Send message
Joined: 4 Sep 11
Posts: 110
Credit: 326,102,587
RAC: 0
Level
Asp
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28655 - Posted: 21 Feb 2013 | 16:11:30 UTC - in response to Message 28653.
Last modified: 21 Feb 2013 | 16:17:04 UTC

I have updated to the latest nVidia driver 314.07, cuda version 5000 for the GTX550Ti.
And guess what happened, I got a: Short runs (2-3 hour on fastest card) 6.52 (cuda42)

So it seems a driver issue after all then...?

I will see how long it takes to complete, estimated 12:32 hours. It is now finishing Einstein@home (they take 35 minutes while BOINC continuously estimate 1hour and 50 minutes).

@microchip, if you can check which driver you are using on the pc that is not getting cuda42 tasks, and is the same as I had before (306.97) then we are pretty sure it's a driver thing. Thanks for your help.
Your statement that you didn't got these tasks either, convinced me to update my drivers.


I also get one in a while, but it's not consistent. I mean I should get a new task before the current one finishes crunching, or sometimes just after it finishes. That's not the case here... Even after hitting the "Update" button once in an hour, it still reports no tasks available for short queue 4.2

If it was a driver issue, I wouldn't get any tasks at all. Also, the long queue works just fine here. It's just the short one that's causing problems so more things point to server side issue

PS: I'm using driver 310.19 on Linux
____________

Team Belgium

Dagorath
Send message
Joined: 16 Mar 11
Posts: 509
Credit: 179,005,236
RAC: 0
Level
Ile
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28666 - Posted: 22 Feb 2013 | 5:49:44 UTC - in response to Message 28655.

Guys....

If there are tasks in the queue the server will send you one. The server does not know which driver you have installed and it doesn't care which driver you have installed.

The reason you do not get tasks when the server status page says there are tasks is because the server status page lies. If you think that when you click the Server Status link that the server then goes and counts all the tasks in the queue and puts the number in the Status Page you see then you are wrong. It does not happen that way. I will explain what happens...

The server counts the tasks in the queues about every 10 minutes then it saves those totals in memory. You come along five minutes later and click the Server Status link and it gives you the numbers it saved from the previous count which happened 5 minutes earlier. Now here is the very, very tricky part so read very, very carefully and think very, very hard, OK? In between the time it counts the tasks in the queues and the time you look at the Server Status other hosts sometimes request work and grab all the tasks. If you understand that then you can understand how you can be looking at the Server Status page and it's telling you 359 tasks (for example) are available but then you click Update in BOINC manager and the Event Log says "no work available". The numbers on the Server Status page are never current which means they are not up to date, they are old info. The report of "no work available" in the Event Log is based on current info therefore you should trust it rather than the Server Status page.

OK, there you have all the information you need to understand this riddle that confuses you. If you still do not understand then you need to start again at the top of my post and read it, repeatedly if necessary, until you understand because that is exactly the way it happens. And if you think I am mistaken then note that there are least 40 other regular readers/posters here who would correct me if I am wrong on this matter and you will note that none of them do.

Yah, Nathan said he put 1,000 tasks in the queue but stop and think.... maybe there are 5,000 hosts that are requesting work from that queue so they gobble it all up within a few minutes?

____________
BOINC <<--- credit whores, pedants, alien hunters

TJ
Send message
Joined: 26 Jun 09
Posts: 815
Credit: 1,470,385,294
RAC: 0
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28668 - Posted: 22 Feb 2013 | 8:33:32 UTC - in response to Message 28666.

The server does not know which driver you have installed and it doesn't care which driver you have installed.


This is not true. I have had many occasions for several projects for AMD as well as nVidia cards that BOINC tells that I need to update my drivers to get work. And indeed after an update I got work then.

Indeed a lot of crunchers think that server pages from all projects lies. And indeed I understand how it works. You can also see how many crunchers are active, how many computers and how many Gigaflops, and do the calculation. Or there are many many more computers and crunchers and perhaps even teraflops, the pages are lying did you know.
____________
Greetings from TJ

Dagorath
Send message
Joined: 16 Mar 11
Posts: 509
Credit: 179,005,236
RAC: 0
Level
Ile
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28670 - Posted: 22 Feb 2013 | 8:45:35 UTC - in response to Message 28668.
Last modified: 22 Feb 2013 | 8:55:59 UTC

The server does not know which driver you have installed and it doesn't care which driver you have installed.


This is not true. I have had many occasions for several projects for AMD as well as nVidia cards that BOINC tells that I need to update my drivers to get work. And indeed after an update I got work then.


OK, I might be wrong about the driver but what I said about the number of tasks in the queue is correct. And if you will think about how the server can say there are (for example) 1000 tasks in the queue and then your host requests work and the server says "no tasks available" well then you see the server does lie. First it says there are tasks, the next second it says there are none. Obviously it cannot be that there are tasks and that there are not tasks simultaneously so obviously the server lies.

If you look near the upper left corner of the Server Status page it gives the server software version number and a time. That is the time the queue totals were last counted. Notice that the time almost never matches the time you clicked the Server Status link.

If what I am saying is not true then what is your explanation for why the server says there are tasks but you cannot get one?

Also, why does it say in your log "no tasks available" instead of "update your driver"?
____________
BOINC <<--- credit whores, pedants, alien hunters

Richard Haselgrove
Send message
Joined: 11 Jul 09
Posts: 1451
Credit: 3,575,929,351
RAC: 345,202
Level
Arg
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28671 - Posted: 22 Feb 2013 | 9:58:20 UTC - in response to Message 28666.
Last modified: 22 Feb 2013 | 10:04:10 UTC

And if you think I am mistaken then note that there are least 40 other regular readers/posters here who would correct me if I am wrong on this matter and you will note that none of them do.

OK, I'm one of them. I haven't up until now, because most of your mis-statements are tiresome rather than fundamentally wrong, but since you've started claiming detailed knowledge, we'd better start picking a few apart.

Driver versions: BOINC servers most certainly do both know and care about driver versions. The easiest project to see this on is Einstein, where the server logs are just a click away, and you can read many messages like 117518.

Server status page: the time in the top left corner is the time the page content was rendered into HTML on the server. If you refresh the page (F5 in my browser), it changes. [Edit: at this project - other projects vary]

However, it is correct that the task counts are collected periodically by a background daemon and stored, and the displayed statistics are taken from the most recent daemon run. I have no idea whether this project has configured the daemon run interval to be 10 minutes - it seems plausible. But to categorise that slight lag in updating as 'lying' is way too far over the top. Tasks on this project run for several hours: to suggest that every single active computer on the project (your 5,000 figure) has collected new work in the last ten minutes, when currently only about 25% of users have been active in the last 24 hours, is absurd - and removes all credibility from the points you are trying to make.

Dagorath
Send message
Joined: 16 Mar 11
Posts: 509
Credit: 179,005,236
RAC: 0
Level
Ile
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28675 - Posted: 22 Feb 2013 | 20:22:06 UTC - in response to Message 28671.

Thank you, Richard, for correcting some of the details I've got wrong. You seem to think that makes me entirely wrong so do explain why TJ sees tasks in the queue on the Server Status page but cannot get a task.

____________
BOINC <<--- credit whores, pedants, alien hunters

flashawk
Send message
Joined: 18 Jun 12
Posts: 297
Credit: 3,572,627,986
RAC: 0
Level
Arg
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwat
Message 28679 - Posted: 23 Feb 2013 | 0:01:45 UTC

I agree with Dagorath, please do tell, you seem to be more informed than either of us and I'm sure there has to be a reason other than just drivers.

Jozef J
Send message
Joined: 7 Jun 12
Posts: 112
Credit: 1,035,595,172
RAC: 0
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwat
Message 28695 - Posted: 23 Feb 2013 | 7:48:47 UTC

I lost during the reinstall nvidia driver, 3 long tasks of course im lost rac for them..sad..
Within last three days I had lost about 50,000 rac in users rankings.Why??? if im turn off my computer im dont lose soo many,exemple.. But I Crunching 24/7 without any errors on my part, but i see some fail jobs in my results.
Now two days i cannot get over 577000..just im circled around..
But i see , many people have same problem..so what happened?
sorry for engl.

flashawk
Send message
Joined: 18 Jun 12
Posts: 297
Credit: 3,572,627,986
RAC: 0
Level
Arg
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwat
Message 28696 - Posted: 23 Feb 2013 | 9:52:34 UTC
Last modified: 23 Feb 2013 | 9:53:41 UTC

Jozef J

Stop doing the short runs and just do the long runs, you're RAC will jump up a bunch. With 2 GTX680's they should take about 5 1/2 hours a wu (the new toni's). I leave the short runs to the less powerful cards.

Profile skgiven
Volunteer moderator
Volunteer tester
Avatar
Send message
Joined: 23 Apr 09
Posts: 3968
Credit: 1,995,359,260
RAC: 0
Level
His
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28698 - Posted: 23 Feb 2013 | 11:45:54 UTC - in response to Message 28675.
Last modified: 23 Feb 2013 | 11:59:46 UTC

Thank you, Richard, for correcting some of the details I've got wrong. You seem to think that makes me entirely wrong so do explain why TJ sees tasks in the queue on the Server Status page but cannot get a task.

Because they are not there - some WU's were removed manually because they were failing/causing problems, as announced here. Presumably when WU's are added to the queue the queue count gets told that 5000 (or whatever the number is) have been added. While it can deal with WU addition, begin sent, server aborted... the Ready To Send Queue is not designed to deal with WU's being manually removed by the researchers, so it probably became inaccurate. Perhaps they would have been better moving them to the Result Deletion Queue, rather than manually deleting them?

Anyway, at least one queue is likely to be removed and this isn't the normal situation. Testing appears to still be underway with several app versions being used over the different queues. The queues will probably be corrected after the testing or experiment seeding is over.
Normally the server status page is accurate to within a few tasks (<10).
____________
FAQ's

HOW TO:
- Opt out of Beta Tests
- Ask for Help

Dagorath
Send message
Joined: 16 Mar 11
Posts: 509
Credit: 179,005,236
RAC: 0
Level
Ile
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28702 - Posted: 23 Feb 2013 | 15:09:57 UTC - in response to Message 28698.

Not there, uh huh. Well, I apologize if this ruffles feathers but where I come from if it says tasks are there when they're not there then it's lying. Some say it's telling "porkies" and that's fine, you know whatever slang works for you, here we call it lying. Not suggesting somebody should be taken out and whipped over it, not saying all operations must cease until it's fixed, just saying it's not truthing i.e. it's lying. If this same situation should occur again in the future and nobody is providing the detailed explanation and guys are needlessly flailing around with driver upgrades... would it be OK if I say something like "the server is not truthing again"? Would that be less offensive?

____________
BOINC <<--- credit whores, pedants, alien hunters

Profile Beyond
Avatar
Send message
Joined: 23 Nov 08
Posts: 1112
Credit: 6,162,416,256
RAC: 0
Level
Tyr
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28703 - Posted: 23 Feb 2013 | 15:24:23 UTC

To me lying is intentionally trying to deceive. I'd say in this case it's simply a mistake, an error with no intention of deception. BOINC client/server has many problems, some far far worse than this. I doubt many of them are intentional.

ExtraTerrestrial Apes
Volunteer moderator
Volunteer tester
Avatar
Send message
Joined: 17 Aug 08
Posts: 2705
Credit: 1,311,122,549
RAC: 0
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28709 - Posted: 23 Feb 2013 | 17:25:36 UTC

TJ, are you getting tasks consistently now, or as erroneous as before the driver update? The driver version really shouldn't cause such behaviour (unless the BOINC log said "driver version xxx too low, please upgrade to at least xxx").

MrS
____________
Scanning for our furry friends since Jan 2002

Profile dskagcommunity
Avatar
Send message
Joined: 28 Apr 11
Posts: 456
Credit: 817,865,789
RAC: 0
Level
Glu
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28711 - Posted: 23 Feb 2013 | 18:49:57 UTC

Only as info: Very soon we run out of long queue Work ;)
____________
DSKAG Austria Research Team: http://www.research.dskag.at



Crunching for my deceased Dog who had "good" Braincancer..

Profile microchip
Avatar
Send message
Joined: 4 Sep 11
Posts: 110
Credit: 326,102,587
RAC: 0
Level
Asp
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28713 - Posted: 23 Feb 2013 | 19:34:09 UTC - in response to Message 28709.

TJ, are you getting tasks consistently now, or as erroneous as before the driver update? The driver version really shouldn't cause such behaviour (unless the BOINC log said "driver version xxx too low, please upgrade to at least xxx").

MrS


Can't speak for TJ, but me I'm getting short tasks consistently now :)
____________

Team Belgium

TJ
Send message
Joined: 26 Jun 09
Posts: 815
Credit: 1,470,385,294
RAC: 0
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28717 - Posted: 23 Feb 2013 | 22:32:46 UTC - in response to Message 28709.

TJ, are you getting tasks consistently now, or as erroneous as before the driver update? The driver version really shouldn't cause such behaviour (unless the BOINC log said "driver version xxx too low, please upgrade to at least xxx").

MrS


Hello MrS, Yes I get tasks consistently. Directly after I did a clean install of the driver and a reboot I got them (cuda42). They take 25xxx to 26xxx seconds on the 550Ti. No BOINC didn't came with a driver this time (306.97 should do it as it ran beta's (cuda42) consistently.

Some off topic information:
On another pc with GTX285 I get consistently cuda31 WU's, they run 16xxx to 17xxx seconds. On the 550Ti they took 40xxx seconds.
____________
Greetings from TJ

Profile microchip
Avatar
Send message
Joined: 4 Sep 11
Posts: 110
Credit: 326,102,587
RAC: 0
Level
Asp
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28736 - Posted: 24 Feb 2013 | 10:14:07 UTC - in response to Message 28717.

TJ, are you getting tasks consistently now, or as erroneous as before the driver update? The driver version really shouldn't cause such behaviour (unless the BOINC log said "driver version xxx too low, please upgrade to at least xxx").

MrS


Hello MrS, Yes I get tasks consistently. Directly after I did a clean install of the driver and a reboot I got them (cuda42). They take 25xxx to 26xxx seconds on the 550Ti. No BOINC didn't came with a driver this time (306.97 should do it as it ran beta's (cuda42) consistently.


My GTX 560 takes 19xxx to crunch a short 4.2 WU under Linux.
____________

Team Belgium

ExtraTerrestrial Apes
Volunteer moderator
Volunteer tester
Avatar
Send message
Joined: 17 Aug 08
Posts: 2705
Credit: 1,311,122,549
RAC: 0
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28738 - Posted: 24 Feb 2013 | 10:31:19 UTC

Thanks for the updates, guys. So in this case it really seemed to be some weird driver issue!

MrS
____________
Scanning for our furry friends since Jan 2002

Profile microchip
Avatar
Send message
Joined: 4 Sep 11
Posts: 110
Credit: 326,102,587
RAC: 0
Level
Asp
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28742 - Posted: 24 Feb 2013 | 11:25:07 UTC - in response to Message 28738.

Thanks for the updates, guys. So in this case it really seemed to be some weird driver issue!

MrS


Not on my side, though. I didn't change drivers at all but work started flowing after one of the scientists submitted 1000 WUs to the short 4.2 queue.
____________

Team Belgium

TJ
Send message
Joined: 26 Jun 09
Posts: 815
Credit: 1,470,385,294
RAC: 0
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28743 - Posted: 24 Feb 2013 | 12:24:33 UTC - in response to Message 28742.

Thanks for the updates, guys. So in this case it really seemed to be some weird driver issue!

MrS


Not on my side, though. I didn't change drivers at all but work started flowing after one of the scientists submitted 1000 WUs to the short 4.2 queue.

And it could be that at the same time I coincidentally did the driver update.
____________
Greetings from TJ

Dagorath
Send message
Joined: 16 Mar 11
Posts: 509
Credit: 179,005,236
RAC: 0
Level
Ile
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28752 - Posted: 25 Feb 2013 | 1:48:51 UTC

Now that that is settled... we still aren't sure if this server (GPUgrid server) will refuse to send tasks due to the driver on the host being "unacceptable", however you want to define unacceptable. It appears Einstein's server is configured to do so but that doesn't mean this project's server is. Can anybody verify it or think of a quick and easy way to test it? I suppose one could install an unacceptable driver and see if they still receive tasks. In fact I would do such a test but I'm not sure which driver(s) might be deemed unacceptable and I don't want to flail about with guesses.

____________
BOINC <<--- credit whores, pedants, alien hunters

TJ
Send message
Joined: 26 Jun 09
Posts: 815
Credit: 1,470,385,294
RAC: 0
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28763 - Posted: 25 Feb 2013 | 15:47:28 UTC - in response to Message 28752.
Last modified: 25 Feb 2013 | 15:49:25 UTC

Now that that is settled... we still aren't sure if this server (GPUgrid server) will refuse to send tasks due to the driver on the host being "unacceptable", however you want to define unacceptable. It appears Einstein's server is configured to do so but that doesn't mean this project's server is. Can anybody verify it or think of a quick and easy way to test it? I suppose one could install an unacceptable driver and see if they still receive tasks. In fact I would do such a test but I'm not sure which driver(s) might be deemed unacceptable and I don't want to flail about with guesses.


My i7, BOINC 7.0.28, GTX285 with driver 280.xx did not get beta's and short runs from CUDA 3.1 and 4.2.
BOINC came with the message that I must update my drivers to get new work.
Thus 280.xx driver is a good "test" one but in my case with a GTX285.
____________
Greetings from TJ

Ken_g6
Send message
Joined: 6 Aug 11
Posts: 8
Credit: 52,496,994
RAC: 0
Level
Thr
Scientific publications
watwatwatwatwatwat
Message 28766 - Posted: 25 Feb 2013 | 18:48:16 UTC

How come one of the "short" queues on the server status page has 10,000+ WUs, but I can't seem to get any of them? I'm running the long WUs fine.

And, come to think of it, why are there two "short" queues? One for 3.1? So are there a bunch of WUs in the 3.1 queue that the server refuses to give me because I can run 4.2 WUs?

ExtraTerrestrial Apes
Volunteer moderator
Volunteer tester
Avatar
Send message
Joined: 17 Aug 08
Posts: 2705
Credit: 1,311,122,549
RAC: 0
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28769 - Posted: 25 Feb 2013 | 19:05:59 UTC - in response to Message 28752.

The server is configured to check the driver version against its CUDA support level, in order to avoid sending WUs to clients which couldn't execute the corresponding app. That should basically be a simple "if driver > xxx then send work" statement.

MrS
____________
Scanning for our furry friends since Jan 2002

TJ
Send message
Joined: 26 Jun 09
Posts: 815
Credit: 1,470,385,294
RAC: 0
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28770 - Posted: 25 Feb 2013 | 19:07:08 UTC - in response to Message 28766.
Last modified: 25 Feb 2013 | 19:09:44 UTC

How come one of the "short" queues on the server status page has 10,000+ WUs, but I can't seem to get any of them? I'm running the long WUs fine.

And, come to think of it, why are there two "short" queues? One for 3.1? So are there a bunch of WUs in the 3.1 queue that the server refuses to give me because I can run 4.2 WUs?

Indeed top is cuda31 and the second is cuda42. This is the same order as on the compute preferences settings. So the 10000+ are the cuda42 ones.
The server can see (I think) for which WU the GPU is best. I get only long runs on my GTX285 when I disable all the others.

Edit; MrS posted when I was typing...
Edit 2, Thanks MrS.
____________
Greetings from TJ

Profile microchip
Avatar
Send message
Joined: 4 Sep 11
Posts: 110
Credit: 326,102,587
RAC: 0
Level
Asp
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28771 - Posted: 25 Feb 2013 | 19:14:07 UTC - in response to Message 28770.
Last modified: 25 Feb 2013 | 19:14:32 UTC

How come one of the "short" queues on the server status page has 10,000+ WUs, but I can't seem to get any of them? I'm running the long WUs fine.

And, come to think of it, why are there two "short" queues? One for 3.1? So are there a bunch of WUs in the 3.1 queue that the server refuses to give me because I can run 4.2 WUs?

Indeed top is cuda31 and the second is cuda42. This is the same order as on the compute preferences settings. So the 10000+ are the cuda42 ones.
The server can see (I think) for which WU the GPU is best. I get only long runs on my GTX285 when I disable all the others.

Edit; MrS posted when I was typing...
Edit 2, Thanks MrS.


Are you sure? According to Nate in the News forum, the top one is the 4.2 queue

http://www.gpugrid.net/forum_thread.php?id=3298&nowrap=true#28658
____________

Team Belgium

flashawk
Send message
Joined: 18 Jun 12
Posts: 297
Credit: 3,572,627,986
RAC: 0
Level
Arg
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwat
Message 28777 - Posted: 25 Feb 2013 | 23:14:08 UTC

So, were out of long runs now? Any idea when we'll be getting more?

Profile microchip
Avatar
Send message
Joined: 4 Sep 11
Posts: 110
Credit: 326,102,587
RAC: 0
Level
Asp
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28793 - Posted: 26 Feb 2013 | 15:39:49 UTC

We seem to have dried up on short WUs. Can we get some more? Thanks
____________

Team Belgium

TJ
Send message
Joined: 26 Jun 09
Posts: 815
Credit: 1,470,385,294
RAC: 0
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28796 - Posted: 26 Feb 2013 | 16:08:09 UTC

Perhaps there is something not quite good with the server. I got these messages from time to time (when I was not watching the pc):
26/02/2013 16:03:06 GPUGRID Sending scheduler request: Requested by project.
26/02/2013 16:03:06 GPUGRID Requesting new tasks for CPU and GPU
26/02/2013 16:03:08 GPUGRID Scheduler request completed: got 0 new tasks
26/02/2013 16:03:08 GPUGRID Message from server: No tasks sent
26/02/2013 16:03:08 GPUGRID Message from server: No tasks are available for Short runs (2-3 hours on fastest card)
26/02/2013 16:03:08 GPUGRID Message from server: No tasks are available for ACEMD beta version
26/02/2013 16:03:08 GPUGRID Message from server: No tasks are available for the applications you have selected.

However, when I request manually by clicking the "update" button I almost immediately get new work.
Perhaps more people have this "issue"?

____________
Greetings from TJ

TJ
Send message
Joined: 26 Jun 09
Posts: 815
Credit: 1,470,385,294
RAC: 0
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28797 - Posted: 26 Feb 2013 | 16:10:23 UTC - in response to Message 28771.


Are you sure? According to Nate in the News forum, the top one is the 4.2 queue

http://www.gpugrid.net/forum_thread.php?id=3298&nowrap=true#28658

Pretty sure as it is mentioned in several posts that the cuda42 is faster then the cuda31. And looking at the server state page and the time WU's are sent back, the fastest must be the cuda42. Or I might have missed something.
____________
Greetings from TJ

Profile microchip
Avatar
Send message
Joined: 4 Sep 11
Posts: 110
Credit: 326,102,587
RAC: 0
Level
Asp
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28798 - Posted: 26 Feb 2013 | 16:55:24 UTC - in response to Message 28797.
Last modified: 26 Feb 2013 | 16:55:45 UTC


Are you sure? According to Nate in the News forum, the top one is the 4.2 queue

http://www.gpugrid.net/forum_thread.php?id=3298&nowrap=true#28658

Pretty sure as it is mentioned in several posts that the cuda42 is faster then the cuda31. And looking at the server state page and the time WU's are sent back, the fastest must be the cuda42. Or I might have missed something.


I wasn't talking about which is fastest, rather about which queue is which. According to Nate, the 4.2 queue is the top one in Server Status.
____________

Team Belgium

Profile Beyond
Avatar
Send message
Joined: 23 Nov 08
Posts: 1112
Credit: 6,162,416,256
RAC: 0
Level
Tyr
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28809 - Posted: 26 Feb 2013 | 19:59:01 UTC

This is all I get:

GPUGRID 02-26-13 13:54 Sending scheduler request: Requested by user.
GPUGRID 02-26-13 13:54 Requesting new tasks for NVIDIA
GPUGRID 02-26-13 13:55 Scheduler request completed: got 0 new tasks
GPUGRID 02-26-13 13:55 No tasks sent
GPUGRID 02-26-13 13:55 No tasks are available for Long runs (8-12 hours on fastest card)

Dagorath
Send message
Joined: 16 Mar 11
Posts: 509
Credit: 179,005,236
RAC: 0
Level
Ile
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28885 - Posted: 28 Feb 2013 | 22:08:04 UTC - in response to Message 28809.

Sure, it can say "no tasks available for long runs" in Event Log and then 5 minutes later you receive a long run. One explanation is that there are in fact none available when you request one but a few minutes later someone returns an errored result so then a resend is made available. Or there are none available then someone returns a success result which allows the server to generate a new task based on that success result (since they generate some tasks "on the fly", IIUC).

____________
BOINC <<--- credit whores, pedants, alien hunters

Profile microchip
Avatar
Send message
Joined: 4 Sep 11
Posts: 110
Credit: 326,102,587
RAC: 0
Level
Asp
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28956 - Posted: 4 Mar 2013 | 12:51:19 UTC

it again dried out :(
____________

Team Belgium

TJ
Send message
Joined: 26 Jun 09
Posts: 815
Credit: 1,470,385,294
RAC: 0
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28964 - Posted: 4 Mar 2013 | 15:18:33 UTC - in response to Message 28956.

it again dried out :(

You can do the 3.1 then, they take longer on my 550Ti, but it keeps the RAC flowing.
____________
Greetings from TJ

Profile microchip
Avatar
Send message
Joined: 4 Sep 11
Posts: 110
Credit: 326,102,587
RAC: 0
Level
Asp
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28966 - Posted: 4 Mar 2013 | 15:39:47 UTC - in response to Message 28964.

it again dried out :(

You can do the 3.1 then, they take longer on my 550Ti, but it keeps the RAC flowing.


Can't. They all error out on my GTX 560. I have the long queue enabled and am crunching a TONI one. Let's see how it goes.
____________

Team Belgium

TJ
Send message
Joined: 26 Jun 09
Posts: 815
Credit: 1,470,385,294
RAC: 0
Level
Met
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 28975 - Posted: 4 Mar 2013 | 18:39:24 UTC - in response to Message 28966.
Last modified: 4 Mar 2013 | 18:40:12 UTC

it again dried out :(

You can do the 3.1 then, they take longer on my 550Ti, but it keeps the RAC flowing.


Can't. They all error out on my GTX 560. I have the long queue enabled and am crunching a TONI one. Let's see how it goes.


I don't have absolutely no knowledge of all the differences in the cards and what they can and can't. I thought that the higher the number the better but that is not true. My GTX285 does faster than the GTX550Ti.
But it could be the driver? I had some issues as I mentioned in another thread and updated to 314.97 now the GTX550Ti does all 4 types of WU's. The long ones error out but we now know why. Just a thought to update drivers. I normally don't do that when things run smooth.
____________
Greetings from TJ

flashawk
Send message
Joined: 18 Jun 12
Posts: 297
Credit: 3,572,627,986
RAC: 0
Level
Arg
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwat
Message 28982 - Posted: 4 Mar 2013 | 20:33:54 UTC

There's over 2200 people hammering the long queue and only 323 on the short one. Now that's greed for ya, they just can't let their RAC's slip down.

Rick A. Sponholz
Avatar
Send message
Joined: 20 Jan 09
Posts: 52
Credit: 2,518,707,115
RAC: 0
Level
Phe
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 29016 - Posted: 6 Mar 2013 | 20:17:09 UTC
Last modified: 6 Mar 2013 | 20:27:31 UTC

My machine with twin GTX590's is not getting any GPUGRID work. the reply to BOINC's request for work is, no work available for short or long. What's up with this? The server status page says, there are plenty of wu's available to send. Are others having the same problem? Rick
____________

Profile Beyond
Avatar
Send message
Joined: 23 Nov 08
Posts: 1112
Credit: 6,162,416,256
RAC: 0
Level
Tyr
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 29017 - Posted: 6 Mar 2013 | 20:32:54 UTC - in response to Message 28982.

There's over 2200 people hammering the long queue and only 323 on the short one. Now that's greed for ya, they just can't let their RAC's slip down.

That that could be seen as a project issue. If they want people to run the short WUs, then make the credits equivalent. Simple.

flashawk
Send message
Joined: 18 Jun 12
Posts: 297
Credit: 3,572,627,986
RAC: 0
Level
Arg
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwat
Message 29018 - Posted: 6 Mar 2013 | 20:34:45 UTC

We're all having problems Rick, the server polls the queue every hour or so when new wu's get generated and dumped in they go pretty quickly. They pulled most of the NOELIA's because they had major issue's.

Rick A. Sponholz
Avatar
Send message
Joined: 20 Jan 09
Posts: 52
Credit: 2,518,707,115
RAC: 0
Level
Phe
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 29019 - Posted: 6 Mar 2013 | 20:39:28 UTC - in response to Message 29018.

Thanks for the reply flashawk. Times are tuff all over, SETI@Home can't download wu's fast enough, and GPUGRID is running out of work. I guess Donate@home, and World Comunitee Grid will get some bonus donations from my hungry for work machines:) Rick
____________

Profile microchip
Avatar
Send message
Joined: 4 Sep 11
Posts: 110
Credit: 326,102,587
RAC: 0
Level
Asp
Scientific publications
watwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwatwat
Message 29145 - Posted: 13 Mar 2013 | 13:11:57 UTC

We've dried out again...
____________

Team Belgium

Post to thread

Message boards : Number crunching : No new work for cuda 4.2

//