Advanced search

Message boards : Number crunching : No usable GPU found in Ubuntu Linux 17.04 (OCT 2017)

Author Message
Dayle Diamond
Send message
Joined: 5 Dec 12
Posts: 84
Credit: 1,590,588,415
RAC: 3,353
Scientific publications
Message 47998 - Posted: 17 Oct 2017 | 19:25:00 UTC

As always, this has been discussed to death but everything I can find is from years back and I don't know what's still relevant. Lot of people suggest trial and error, but I'm so new with the OS that I couldn't easily recover from a mistake.

Please bear with me, this is my first Ubuntu build after running windows for over 20 years.

I'm running the latest desktop version of Ubuntu.
Tried to update to the newest drivers from Nvidia's website, but the computer tried to open them as a massive text file.

So I found instructions online to install via a PPA. Not that I know what that stands for. Can't find my instructions, but it was something like this

Now my system is showing my computer running driver version 384.90.

I'm not up on my theory yet, just need to know what to type.
If it works, we'll have a 980-ti running on my office desktop (ie) a dedicated crunching machine.

Thanks folks,

Dayle Diamond

Send message
Joined: 23 Dec 09
Posts: 189
Credit: 3,940,641,417
RAC: 2,012,389
Scientific publications
Message 48000 - Posted: 18 Oct 2017 | 0:04:44 UTC

Although I use Lubuntu 17.04. I do not think it is much different to Ubuntu 17.04.

Especially with the newest version of Lubuntu, I have never had problems that BOINC recognizes my GPU.

I do the following: Install under System Tools, with the Synaptic Package Manager, boinc-client-nvidia-cuda package and then under Preferences with Additional Drivers the latest nVidia-binary-driver.

It always worked so far.

Post to thread

Message boards : Number crunching : No usable GPU found in Ubuntu Linux 17.04 (OCT 2017)