Advanced search

Message boards : Graphics cards (GPUs) : New laptop has an Nvidia 4070 and AMD GPU

Author Message
afielder
Send message
Joined: 23 Jan 09
Posts: 1
Credit: 5,051,464
RAC: 0
Level
Ser
Scientific publications
watwatwatwatwatwatwatwatwat
Message 60755 - Posted: 19 Sep 2023 | 8:53:20 UTC

Hi all, I haven't had a system with an Nvidia GPU in some time, and have never owned a laptop which had both AMD/Nvidia.

Does someone have an app_config.xml they can share which will force GPUGRID to run work units on the Nvidia card?

FWIW here is mine but the BOINC client complains the app names are incorrect:


<app_config>
<app>
<name>PythonGPU</name>
<max_concurrent>9999</max_concurrent>
<gpu_versions>
<gpu_usage>1</gpu_usage>
<cpu_usage>0.001</cpu_usage>
</gpu_versions>
</app>
<app>
<name>acemd3</name>
<max_concurrent>9999</max_concurrent>
<gpu_versions>
<gpu_usage>1</gpu_usage>
<cpu_usage>0.001</cpu_usage>
</gpu_versions>
</app>
<app>
<name>acemd4</name>
<max_concurrent>9999</max_concurrent>
<gpu_versions>
<gpu_usage>1</gpu_usage>
<cpu_usage>0.001</cpu_usage>
</gpu_versions>
</app>
<app>
<name>ATM</name>
<max_concurrent>9999</max_concurrent>
<gpu_versions>
<gpu_usage>1</gpu_usage>
<cpu_usage>0.001</cpu_usage>
</gpu_versions>
</app>
</app_config>


Having briefly read the documentation, it seems as though I should add this somewhere but I am unclear as to where exactly: <use_all_gpus>1</use_all_gpus>

Thanks,

Alex.

Keith Myers
Send message
Joined: 13 Dec 17
Posts: 1312
Credit: 5,915,004,959
RAC: 6,445,778
Level
Tyr
Scientific publications
watwatwatwatwat
Message 60756 - Posted: 19 Sep 2023 | 20:30:18 UTC - in response to Message 60755.

You need to change the ATM name to ATMbeta. You might as well remove the acemd4 section. Very doubtful we will ever see those briefly available tasks again.

You do need to use the use_all_gpus statement in the cc_config.xml file.

Also input an exclude gpu section in <Options> to keep any gpu work off the embedded ATI/AMD igpu.

Easiest is to just exclude the device number in a statement. Look at the Event Log startup to see how BOINC enumerates both devices.

The Nvidia card should enumerate at device0 theoretically as the most capable device. With the ATI igpu enumerated as device1.

So excluding device1 is probably what you need. Something like this:

<exclude_gpu>
<device_num>1</device_num>
<type>ATI</type>
</exclude_gpu>


Read through the client and application documentation.

https://boinc.berkeley.edu/wiki/Client_configuration#Application_configuration

Post to thread

Message boards : Graphics cards (GPUs) : New laptop has an Nvidia 4070 and AMD GPU

//